Vlc graphics corruption

video

#1

Hello everyone,

i’ve just installed ubuntu mate 18.04 on my acer aspire 5530.

I’ve tried to open a video with vlc and i see a lot of gfx corruption.

the notebook is about 2009 and has a dual radeon card. I have tried disabling compositing and enabling compiz, but nothing seems to change.

Video that gets corrupted here (wetransfer link): https://we.tl/v0S1hMLm9k (downloaded from yt with jdownloader)

Edit: Full link here: https://wetransfer.com/downloads/437da5b59a1a14ca3b033cd18a6ae35c20180712134130/10c143

Screenshot attached.

mpv and mplayer are working fine.

Thank you in advance for any suggestion.

Inxi -f

Kernel: 4.15.0-23-generic x86_64
           bits: 64
           Desktop: MATE 1.20.1  Distro: Ubuntu 18.04 LTS
Machine:   Device: laptop System: Acer product: Aspire 5530 v: V1.11 serial: N/A
           Mobo: Acer model: Cinder Cone serial: N/A
           BIOS: Acer v: V1.11 date: 08/06/2008
Battery    BAT1: charge: 33.2 Wh 85.0% condition: 39.0/48.8 Wh (80%)
CPU:       Dual core AMD Turion X2 Mobile RM-70 (-MCP-) cache: 1024 KB
           clock speeds: max: 2000 MHz 1: 2000 MHz 2: 1000 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] RS780M [Mobility Radeon HD 3200]
           Card-2: Advanced Micro Devices [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: [email protected]
           OpenGL: renderer: AMD RV620 (DRM 2.50.0 / 4.15.0-23-generic, LLVM 6.0.0)
           version: 3.3 Mesa 18.0.5
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] RV620 HDMI Audio [Radeon HD 3450/3470/3550/3570]
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network:   Card-1: Broadcom Limited BCM4312 802.11b/g LP-PHY driver: wl
           IF: wlp6s0 state: up mac: 00:23:4d:9a:45:6d
           Card-2: Broadcom Limited NetXtreme BCM5764M Gigabit Ethernet PCIe
           driver: tg3
           IF: enp7s0 state: down mac: 00:1e:ec:d4:25:9a
Drives:    HDD Total Size: 240.1GB (24.6% used)
           ID-1: /dev/sda model: KINGSTON_SA400S3 size: 240.1GB
Partition: ID-1: / size: 17G used: 5.4G (35%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 195G used: 43G (23%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 8.26GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 59.5C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 167 Uptime: 6 min Memory: 955.4/3690.2MB
           Client: Shell (bash) inxi: 2.3.56 
[email protected]:~$ inxi -F
System:    Host: raffaella-Aspire-5530 Kernel: 4.15.0-23-generic x86_64 bits: 64 Desktop: MATE 1.20.1
           Distro: Ubuntu 18.04 LTS
Machine:   Device: laptop System: Acer product: Aspire 5530 v: V1.11 serial: N/A
           Mobo: Acer model: Cinder Cone serial: N/A BIOS: Acer v: V1.11 date: 08/06/2008
Battery    BAT1: charge: 33.2 Wh 85.0% condition: 39.0/48.8 Wh (80%)
CPU:       Dual core AMD Turion X2 Mobile RM-70 (-MCP-) cache: 1024 KB
           clock speeds: max: 2000 MHz 1: 1000 MHz 2: 2000 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD/ATI] RS780M [Mobility Radeon HD 3200]
           Card-2: Advanced Micro Devices [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
           Display Server: x11 (X.Org 1.19.6 ) drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: [email protected]
           OpenGL: renderer: AMD RV620 (DRM 2.50.0 / 4.15.0-23-generic, LLVM 6.0.0) version: 3.3 Mesa 18.0.5
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] RV620 HDMI Audio [Radeon HD 3450/3470/3550/3570]
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network:   Card-1: Broadcom Limited BCM4312 802.11b/g LP-PHY driver: wl
           IF: wlp6s0 state: up mac: 00:23:4d:9a:45:6d
           Card-2: Broadcom Limited NetXtreme BCM5764M Gigabit Ethernet PCIe driver: tg3
           IF: enp7s0 state: down mac: 00:1e:ec:d4:25:9a
Drives:    HDD Total Size: 240.1GB (24.6% used)
           ID-1: /dev/sda model: KINGSTON_SA400S3 size: 240.1GB
Partition: ID-1: / size: 17G used: 5.4G (35%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 195G used: 43G (23%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 8.26GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 58.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 167 Uptime: 6 min Memory: 956.1/3690.2MB Client: Shell (bash) inxi: 2.3.56

#2
$ dpkg -l |grep vlc


ii  libvlc-bin:amd64                      3.0.2-0ubuntu0.1                    amd64        tools for VLC's base library
ii  libvlc5:amd64                         3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer library
ii  libvlccore9:amd64                     3.0.2-0ubuntu0.1                    amd64        base library for VLC and its modules
ii  vlc                                   3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer
ii  vlc-bin                               3.0.2-0ubuntu0.1                    amd64        binaries from VLC
ii  vlc-data                              3.0.2-0ubuntu0.1                    all          common data for VLC
ii  vlc-l10n                              3.0.2-0ubuntu0.1                    all          translations for VLC
ii  vlc-plugin-base:amd64                 3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer (base plugins)
ii  vlc-plugin-notify:amd64               3.0.2-0ubuntu0.1                    amd64        LibNotify plugin for VLC
ii  vlc-plugin-qt:amd64                   3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer (Qt plugin)
ii  vlc-plugin-samba:amd64                3.0.2-0ubuntu0.1                    amd64        Samba plugin for VLC
ii  vlc-plugin-skins2:amd64               3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer (Skins2 plugin)
ii  vlc-plugin-video-output:amd64         3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer (video output plugins)
ii  vlc-plugin-video-splitter:amd64       3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer (video splitter plugins)
ii  vlc-plugin-visualization:amd64        3.0.2-0ubuntu0.1                    amd64        multimedia player and streamer (visualization plugins)

#3

Just tried with a Packard Bell imedia 8650-AIO, with an NVIDIA G86 [GeForce 8300 GS] using proprietary drivers, and works fine without compiz, with compiz skips some frame but it has always been this way, so i think it’s related to the gfx card.

$ inxi -F
System:    Host: IMEDIA-8650-AIO Kernel: 4.15.0-20-generic x86_64 bits: 64 Desktop: MATE 1.20.1
           Distro: Ubuntu 18.04 LTS
Machine:   Device: desktop Mobo: Packard Bell BV model: MCP61DM2MA v: 1.XX serial: N/A
           BIOS: Phoenix v: PBAMARMB.0400 date: 05/15/2007
CPU:       Dual core AMD Athlon 64 X2 6000+ (-MCP-) cache: 2048 KB
           clock speeds: max: 3013 MHz 1: 3013 MHz 2: 3013 MHz
Graphics:  Card: NVIDIA G86 [GeForce 8300 GS]
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: [email protected]
           OpenGL: renderer: GeForce 8300 GS/PCIe/SSE2 version: 3.3.0 NVIDIA 340.106
Audio:     Card NVIDIA MCP61 High Definition Audio driver: snd_hda_intel Sound: ALSA v: k4.15.0-20-generic
Network:   Card: NVIDIA MCP61 Ethernet driver: forcedeth
           IF: enp0s7 state: up speed: 100 Mbps duplex: full mac: 00:1c:25:24:9d:0d
Drives:    HDD Total Size: 160.0GB (12.4% used)
           ID-1: /dev/sda model: ST3160212AS size: 160.0GB
Partition: ID-1: / size: 19G used: 6.3G (37%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 116G used: 660M (1%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 13.04GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 40.0C mobo: N/A gpu: 52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 173 Uptime: 5 min Memory: 1284.9/5961.8MB Client: Shell (bash) inxi: 2.3.56

#4

apologies I couldnot use your link.

perhaps if you used frama.link that may-well help.


#5

Here is the full link: https://wetransfer.com/downloads/437da5b59a1a14ca3b033cd18a6ae35c20180712134130/10c143


#6

Hi @francesco,

I know there’s a lot to choose from but I’d try some different output modes in VLC. Many, including myself, have found “Automatic” just doesn’t do it for many environments and it needs to be set. And it’s a pain but VLC needs to restart to test each.

Hope this helps.


#7

Thank you! Choosing XVideo output (XCB) works almost fine (even if a bit sluggish).