Vlc playback jumpy and generally poor

Video playback is poor using vlc better with mp4 player. I have a desktop not a raspberry pi. If I run:

vlc -vvv

from a terminal and start a specific video it returns details about dropped frames.

Could this be missing codecs (ubuntu-mate 16.06 with ubuntu-restricted-extras, note no ubuntu-mate-restricted-extras) or a duff install?

Heathrobinson.

Hi @heathrobinson,

could be bugs from the new 16.04 Ubuntu release, try doing a full system update!:

Hello Wolfman,

I did system update and although it updated " the launcher" it did nothing to ease the problem. Here is a sample output from the vlc -vvv command with a video running:

core video output warning: picture is too late to be displayed (missing 99 ms)
[00007f0c9e225908] avcodec decoder warning: plane 0 not aligned
[00007f0c9e225908] avcodec decoder warning: disabling direct rendering
[00007f0c9e225908] avcodec decoder debug: enabling direct rendering
[00007f0c9000ebd8] core video output warning: picture is too late to be displayed (missing 188 ms)
[00007f0c9000ebd8] core video output warning: picture is too late to be displayed (missing 148 ms)
[00007f0c9e225908] avcodec decoder warning: plane 0 not aligned
[00007f0c9e225908] avcodec decoder warning: disabling direct rendering
[00007f0c9000ebd8] core video output warning: picture is too late to be displayed (missing 230 ms)

Might it be worth purging vlc and re-installing, installing gnome-mplayer or just waiting for an update to fix it. Is 14.04 prone to similar problems?

Heathrobinson.

1 Like

Yes, try changing your software sources download location and then re-installing it!. :smiley:

it looks like your CPU isn’t keeping up with the demand. Does it run at 100%? How big of a display are you trying to render it on?

Are you running the right video driver? In terminal:

inxi -G

if you run it as cvlc -vvv --zoom=0.5 VIDEO-FILE-NAME does it still drop frames? if not your CPU bound.

Output of inxi -G

Graphics: Card: VIA CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]
Display Server: X.org 1.18.3 drivers: fbdev (unloaded: vesa)
tty size: 98x28 Advanced Data: N/A for root
[email protected]:~$ inxi -G
Graphics: Card: VIA CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]
Display Server: X.Org 1.18.3 drivers: fbdev (unloaded: vesa)
Resolution: [email protected]
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
GLX Version: 3.0 Mesa 11.2.0

Not too sure what “unloaded: vesa” means ie was it adopted or dropped?
I think the 128 bits could be expanded in the bios, just how much control the bios has once the kernel has started I’m not sure but presumably could still limit the flow.

Heathrobinson.

Output/result of “cvlc -vvv —zoom=0.5 filename”

Its worth noting that it normally opens in a reduced size of screen and when the “zoom=0.5” is employed it occupies about a 12th of the screen. The jumpiness goes away and the sound is almost in sync (there are still warnings) but when you try to drag the frame to expand the image it drops frames and the jumpiness returns, see output:

[00007facce225828] avcodec decoder warning: plane 0 not aligned
[00007facce225828] avcodec decoder warning: disabling direct rendering
[00007facb4001e88] xcb_window window error: X server failure
[00007facbc00ed58] core video output warning: picture is too late to be displayed (missing 165 ms)
[00007facbc00ed58] core video output warning: picture is too late to be displayed (missing 125 ms)
[00007facbc00ed58] core video output warning: picture is too late to be displayed (missing 86 ms)
[00007facbc00ed58] core video output warning: picture is too late to be displayed (missing 46 ms)
[00007facbc00ed58] core video output debug: picture might be displayed late (missing 6 ms)
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 72 (X_PutImage)
Resource id in failed request: 0x3400000
Serial number of failed request: 22743
Current serial number in output stream: 22745

Rather oddly gnome-mplayer renders the video much better with just a bit of lag on the audio. While my graphics are a little crude to say the least it does suggest all is not well with this version vlc. Oh yes as the picture gets bigger the more the cpu maxes out (Intel® Core™2 CPU).

Heathrobinson.