Volume Control - GONE!

I have been using Ubuntu MATE 14.04 for some time now and have only just noticed that all volume and sound controls have vanished!

The Volume control has gone from the Notification Area in the MATE Panel and there are no mixer or other sound controls available in the Applications or System menus.

The sound on my PC is still working, though the only volume controls I have left are in various apps and the master volume control on my speakers.

I tried to restore the Volume / Sound control to the Panel, but no Sound Control is present in the Notification Area or the Panel’s ‘Add’ menu.
All controls for my sound card are missing: lspci shows it correctly as “Creative Labs SB Live! EMU10k1 (rev 04)”

As I say, my PC sound system was all present, correct and working, but now the panel Volume control has gone and I have no access to the mixer or equaliser controls.

Any ideas?

Hi,

try the following command:

sudo mate-panel --reset

Log out and back in again after running the above command!.

You can install the package “paman” which is the Pulse Audio Manager!.

You can also try running the following terminal commands to see if it fixes the problem:

sudo apt-get –fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get –fix-broken install

The above command downloads and installs any broken dependencies on your system.

Hope it helps!. :smiley:

I tried

sudo mate-panel --reset

which cleared everything from the panel except Firefox.
After restoring Calendar, Notification Area and various launchers to the panel, it remains the same as before - no Volume Control

Both

sudo apt-get –fix-missing install

and

sudo apt-get –fix-broken install

throw “E: Invalid operation” errors - ???

Installing Pulse Audio Manager seems to have replaced whatever sound & volume controls I had with the Pulse Audio version, which provides the same functions but in a different styling.

It installed configured for “Analogue Surround 5.1”, which worked, though at a very low volume. I have a “4.1” set-up, but selecting “4.1” gives “pulsed/choppy” sound.
Selecting “4.0” sounds fine though, so I’ll stick with that.

Thanks for your help.

Hi,

have you looked in the "add to panel" tool to see if the sound applet is there?. (Right click on top panel!). :smiley:

You can also try the following commands:

sudo dpkg --configure -a

then:

sudo apt-get install -f

Also try the following command but make sure your software sources download location is set to "Main server"!:

sudo apt-get update && sudo apt-get dist-upgrade -f

See also: