Volume scroll-wheel doesn't work in 16.04


I found a small bug or incompatibility. On my Corsair K90 keyboard I have a scroll-wheel for controlling volume; in 16.04 volume up (scrolling up) doesn’t work (scrolling down to turn down the volume works however). It works fine in Windows and it worked fine in 15.10.

If there is a solution to the problem then I would be very grateful :slight_smile:


Hi Lukasz

I do not have any first hand experience with this product, but I went to the corsair forum and found this…



and this


1 Like

Hi @Lukasz_Erecinski, I have Ubuntu MATE 15.10 installed currently and am an owner of a Corsair K70 Keyboard (which has a volume scroll wheel as well). I don’t have 16.04 installed at the moment however I plan to install it when it comes out.
The scroll wheel works in 15.10. I hope it’ll work in 16.04 as well ! I’ll be sure to report on that.

1 Like

Thank you, this really helped. I have managed to get the driver and everything works as it should ! Was easy enough, even for a Linux illiterate like myself :wink:

1 Like

Yea, in 15.10 it works without a problem. Its only on 16.04 that the scroll-wheel became an issue; so when you make the transition make sure to use: https://github.com/cvuchener/k90-linux-driver

Cheers :slight_smile:

1 Like

Excellent :smiley:

Don’t forget to mark this solved :wave:

sorry, I keep forgetting :scream:

I had today this exact same issue with my K90, I tried to apply that K90 linux driver but still had no result, but then I found http://forum.corsair.com/v3/showthread.php?t=133929 ckb, in the usb.h i had to change 0x1b08 and 1b08 to 0x1b02 and 1b02 and everything worked perfectly, it’s kind of odd that in *buntu 16.04 it stops registering the XF86AudioRaiseVolume with corsair keyboards

Ah good to know. Thanks for this :slight_smile:

Think you could explain a bit more ? tried going back and editing usb.h in /usr/include but when I nano it, there is nothing there. Help would be appreciated.