Wake on LAN Persistance Issues 22.04

Hi there Pavlov, I'm sorry to drag you back into this but I was wondering if you could help me with a situation similar to Tim's.

Same situation entirely: I'm using my laptop (also a Lenovo Thinkpad T420) as a server and need to stash it somewhere with the lid closed. I'm using an Ikea Utespelare Desk (link gives you an image), which has a cable runway underneath the desktop where I store my laptop. WOL works perfectly when the lid is open, and you already know what happens when the lid is shut.

I've enabled WOL and created a service that runs every time it starts up. This was confirmed in that log you see every time you boot up the server version of Ubuntu, saying that wake on LAN was successfully enabled. The laptop is connected to power (I've removed the battery) and is connected to my router via ethernet.

I've gone into logind.conf and set anything related to the lid switch to "ignore". The laptop stays on when shutting the lid and I can use SSH to access it.

The problem begins once I use "sudo shutdown now" to turn it off remotely. At that point it's completely unreachable via WOL. I used TCPDump to confirm that the laptop was even receiving the magic packets at all, and it was.

Any help is appreciated, thank you for taking the time to read this.

1 Like

in the T420 BIOS, did you set Config > Network > Wake on LAN > AC Only ?

I just tried that and it worked, even with the lid shut. Unfortunately, once I put my laptop back and tried again, nothing happened.

in Settings > Power options, you should have do nothing when the lid closes.

To sum up: T420 laptop, when the lid closes, it does nothing. Turn off the laptop with sudo poweroff. The WOL service is installed and uses ethtool to set wol to g. You send a magic packet to the mac address and it wakes up. You can add comments to /var/log/syslog using logger. I dont see issues.


Welcome @Aarnav_Sharma to the community!

I'll try that tomorrow and let you know how it goes. Thanks for your help!