Wake on LAN Persistance Issues 22.04

Hello,

Tried enabling Wake on LAN through ethtool sudo /usr/sbin/ethtool --change eno1 wol g however this only works until the last reboot.

When I reboot, I run sudo ethtool eno1 and "Wake-on:" always gets reverted back to "d". Even tried to create a service to automatically change the configuration but this never seems to work.

Wake on LAN in enabled on the BIOS correctly since I installed Pop OS 22.04 on the same system and everything works even after reboots. The system is an Intel NUC6i3SYB.

Thank you for your help in advance.

Here are my notes from way back, create a wol.service

REF: Persistent Wake-On-LAN option? | Proxmox Support Forum

cat <<EOF | sudo tee /etc/systemd/system/wol.service

[Unit]
Description=Wake-on-LAN for eth0
Requires=network.target
After=network.target

[Service]
ExecStart=/sbin/ethtool	 -s eth0 wol g
ExecStop=/sbin/ethtool	 -s eth0 wol g

[Install]
WantedBy=multi-user.target 
EOF


systemctl start wol.service
systemctl enable wol.service
systemctl is-enabled wol.service
systemctl daemon-reload
1 Like

@pavlos_kairis Thanks for getting back but it's still not working. I added the service and rebooted. Do not have the "g" set - it still goes back to "d"

I noticed when I run the service manually (it switches to "g"), then click Suspend > and wake it manually - the card is set back to "d"

I really don't want to have to switch from MATE to Pop OS, but maybe it's the only way to fix the issue.

Are other people having issues on WoL with 22.04 as well? I can't be the only one experiencing this, right?

I just tested this on my pc (wfx) ...

went into BIOS, enabled Wake-on-LAN
Added wol.service as above (Note: ethtool is in /sbin, not /usr/sbin)
Logged on to that pc, sudo poweroff
From another pc, ping wfx ... Destination unreachable
Went to my router, sent a magic packet to wfx.
After a while (wfx booted), ping became active.

Instead of powering off ...

ssh wfx, sudo systemctl suspend, wfx should become inactive.
From router, send a magic packet, after a bit, wfx becomes active.

(All tested before I wrote this post.)

1 Like

Now that I updated from 20.04 to 22.04, I am seeing the same problem. I also had it before once that I updated from 20.04 to 20.10 in another computer.

The solution is to write WOL_DISABLE=N in the file /etc/tlp.conf

See also: Trouble with wakeonlan with Ubuntu 20.04 - Ask Ubuntu
systemd - wakeonlan with Ubuntu 20.10 stopped working - Ask Ubuntu