Waking from suspend does not prompt for password

Yesterday I created a minimal install of Ubuntu MATE 20.04.01 and I have let it update. When I close the lid and then reopen it I am asked for my password, but if I suspend my laptop with: systemctl suspend , or select suspend from the menu, and then power it back on I am immediately taken to my desktop and not prompted for my password.

I have to enter my crypt passphrase before the grub menu displays, so I have had Don't ask for a password on login enabled, and in case that was the issue I disabled it and rebooted but still waking from suspend does not prompt for my password.

After reading adding the startup command gnome-screensaver & could resolve this I added mate-screensaver & but this did not help.

In dconf-editor I have the following enabled:

/org/mate/power-manager/ >> lock-suspend, lock-blank-screen, lock-use-screensaver, lock-keyring-suspend, lock-use-screensaver
/org/mate/screensaver/ >> lock-delay = 1, lock-enabled
/org/gnome/desktop/screensaver/ >> lock-delay = 0, lock enabled, ubuntu-lock-on-suspend

I have tried the mate screensaver lock delay at 0 also.

Is there something else I can try please?

There is an existing bug report on this issue, please add your comments and click on this affects you.

1 Like

Thanks, I will after I try more of the fixes I found. Before I do that though I want to setup timeshift so I can easily rollback, and I have just discovered some other bug preventing me from progressing.

I will post back here with my findings for the suspend and lock issue.


This thread is old, but it's what's happen with my computer

  • Ubuntu Version 22.04.3 LTS (Jammy Jellyfish) 64-bit
  • MATE 1.26.0

The behavior differs depending on the standby method used:

  • wakeup after suspend via lid closed : password prompt
  • wakeup after suspend via applet menu "suspend (Mettre en veille)" : no password prompt

I tried to set dconf but no change :frowning:

Thanks & cheers :slight_smile: