waterfox-G4.0.2.1.en-US.linux-x86_64.tar.bz2 installation

I would like to use Waterfox. I am a total GUI guy and have never successfully extracted and moved a program in Linux. I have read many generic tutorials, but none work. Right now I am using a Waterfox appimage, but it is three years old. Also opensussie is no longer supporting either the Waterfox repository or appimage. which is from 2018. When I extract the latest waterfox-G4.0.2.1.en-US.linux-x86_64.tar.bz2 file there is no readme or config file:

no config.png

Clicking the Waterfox file gave me this a previous post says it should open Waterfox:

Can anyone write or point me to a good step by step detailed tutorial for installing a .tar.bz2 file or Waterfox?
I would greatly appreciate it.

Can you install it using snap, eg. sudo snap install --edge waterfox-classic

Not a fan of snaps. I have already extracted it with engrampa archive manager, maybe all I need is the command to move it to the proper folders and make it executable?
I have already extracted it with engrampa archive manager in my download folder, maybe all I need is the command to move it to the proper folders and make it executable?

make /opt if you don't have it (sudo mkdir /opt)
sudo mv ~/Downloads/waterfox-G4.0.2.1.en-US.linux-x86_64.tar.bz2 /opt
cd /opt
sudo tar -xjvf waterfox-G4.0.2.1.en-US.linux-x86_64.tar.bz2
cd /opt/waterfox


(tested on ubuntu mate 20.04) ... You can edit menus, add new item in Internet, provide the name, command, click on the icon, navigate to /opt/waterfox/icons/ and select the updater.png icon.

1 Like

Thank You, worked great. I have it up and running.

Not sure why you try to open the -bin file?
If I unpack the .bz2 file and double click the waterfox file, it worked.
Another way is to download a .deb file from maybe:

Install it with GDebi Installer from caja.

1 Like

I didn't try to open the bin file, just the one named Waterfox. I just made a mistake on the screenshot. Waterfox would not open on my system.
Thanks for the link, the ones I found were all obsolete. Yes I would rather use a .deb file.

Not sure, but is the file executable?
A little help:

I have another laptop I wanted to put Waterfox on, but it fails on this laptop (Dell).
I cannot move the waterfox-bin file to set a menu item.
Here is my terminal output:

Otherwise the instructions pavlos_kairis had given me worked on my other installations.

Is there a reason to install to /opt ?
Why not use a .deb file and GDebi to install normally to /usr/bin ?
I'm also not sure that when install to /opt an update will work.

Yes, that is where web browsers go. I tried putting it to usr/bin and it was not recognized. No it will not update automatically, you have to re-install each update from a tarball. I was able to put on Waterfox Classic with a PPA that will update automatically, but prefer the newer Waterfox releases. Still I can live with Waterfox Classic.

OK, I thing something went wrong....
Which distribution you are using? Try: $ uname -a & lsb_release -a
Print output.
Try: $ apt list caja
Print output.
if caja is not installed, try: sudo apt install caja
Try: $ apt list gdebi
Print output.
If gdebi is not installed, try: sudo apt install gdebi

Where is your waterfox-kit? What kind of kit (.tar.gz or .deb)
The current waterfox-kit is on: https://software.opensuse.org//download.html?project=home%3Ahawkeye116477%3Awaterfox&package=waterfox-classic-kpe
If you are on Ubuntu, try Ubuntu and then grab binary package.
Check for right version and download. It is the .deb-file
Start caja from menu or from terminal. Go to your download directory.
Right click on the downloaded .deb-file and try gdebi installation program. This install waterfox-classic to standard.
Try: $ sudo apt list water*
It should look like "waterfox-classic-kpe/now 2021.11-0+77.1 amd64 [Installiert,lokal]"
If that work, try removing waterfox from /opt and remove waterfox-tar directory from wherever you have unpacked it.
Newer versions (updates) will be found on the used link.
If update is available, download the .deb file and installed as done before. It will update the running version and is ready after restart waterfox. Waterfox is not update by the system, you have to check for updates from time to time. I don't know if and when waterfox will find it's way to the ubuntu-repositories.
Forgot the hassle with tarball installation.
Hope this helps

I think you are misunderstanding my question. Waterfox is only released as a tarball, no other way, no .deb file, no PPA. . Waterfox classic, which is like Palemoon or the old Firefox is a PPA hosted by OpenSusse.

I was able to install Waterfox Classic without a problem on an older Dell Inspiron running Ubuntu Mate with NO PROBLEM.
It is only when I try to move the bin file when installing the new tarball extracted Waterfox that I have a problem. I have installed Waterfox on another laptop I use with Linux Mint with no problem
(and have updated it twice so three different releases with no problems).

I have two older Dell Inspiron computers running Ubuntu Mate 20.04 LTS up to date and both give the same error. I am thinking there was a corruption in the ISO in Javascript that didn't show up in the SHA1 hash or it was corrupted when Etcher wrote it to the USB drive.
I used a Torrent to download it and Etcher to burn it. I seldom install tarballs so it is not a great problem. But I wonder if I need to will I be able too do so.
As I said for now I can live with Waterfox Classic rather than Waterfox. 2023 and the new LTS isn't that far away.
Thanks for trying.

OK, now it's clear to me. I have the same LTS and no problem downloading, installing and running the G4.0.4 .bin
To verify your problem you can download and burn the Mate-ISO again.
If you boot it as live version, you should be able to try the installation for testing. Did your installation is 20.04 or the latest 20.04.3?

I can give that a try, hadn't thought of that. It was 20.04.3.

I tried Ubuntu Mate and POP from a USB, and did a quick install of Debian, Sparky and Mint. It must be something about the laptop itself, it is an older Dell but it would not work on any of those, and all gave the same error. I will just use Waterfox Classic for now, so closed (solved) again.

I found a different tutorial than the one pavlos gave me that finally allowed me to install Waterfox on my Dell laptop using Ubuntu Mate 22.04 LTS. It is a bit different for setting the the menu in bin.