Weak wifi - Wifi signal suddenly too weak to be reliable

Hi folks,

I have been enjoying Ubuntu Mate for a couple of years now and for the past year it's been trouble free (I had some issues when I got started and those seem to have cleared up as updates came along to address them).

Recently, the wifi signal on my Dell Inspiron 15 has gotten very weak. I had this issue before and learned that I could turn off Power Management, which I did and the wifi signal instantly jumped up and all was well. I noticed that the wifi signal had again become weak and I checked the status of Power Management and I saw that it was back on. I figured a recent update probably reset something so I turned it off again, but this time my wifi signal did not jump up like it did before. It's as though Power Management is not really getting turned off even though it says it is.

This laptop is the only wireless device in my home that has an issue with a weak signal, so I'm thinking it's not my router (every other device works fine from anywhere in the house, like this laptop used to).

Here's what I'm seeing when I look at iwconfig...

[email protected]:~$ iwconfig
wlp6s0 IEEE 802.11 ESSID:"surveillance van"
Mode:Managed Frequency:2.462 GHz Access Point: B0:39:56:20:3D:12
Bit Rate=28.9 Mb/s Tx-Power=22 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=35/70 Signal level=-75 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:19 Invalid misc:980 Missed beacon:0

lo no wireless extensions.

enp7s0 no wireless extensions.

This is the signal quality I have sitting 10 feet from my router. :frowning_face:
I'm hoping somebody here will know what could be causing this issue and offer a solution.

Thank you in advance to any help.

--neal

1 Like

Hi I am on a tower so can not claim to be an expert but some wifi drops relate to too many other users/neighbours on the same frequency.
They do not use your net but they interfere which CAN cause slowness.

quick way to test is to use your smart phone and look at your router either 2.4 or 5 GHz
if you see lots.....it may be interference

so setup your router to a specific channel that no-one or few are using
ref
https://www.linuxquestions.org/questions/linux-wireless-networking-41/signal-strength-link-quality-etc-4175625295/

aus9,

Thank you for the reply. I have tried setting my router to a specific channel but there was no difference that I could see with the wifi signal strength on this laptop, unfortunately. I have since set the router channel back to Auto.

--neal

First off, you need to identify what the wifi card in the machine is, via "lspci". If it turns out that it's a Realtek card, get the EXACT model number (it'll have a name like RTL8230BE etc) and post it here.
If it is one, you're probably in luck, because the main reason for those suddenly not working is either the 4.4 kernel driver for them sucking, or the card randomly choosing the wrong antenna at boot, and both of those problems have easy fixes.
(Although the Realtek CARDS nearly all support two antennae, the MACHINES typically only attach ONE of them. By default, the driver has to guess which one is actually wired up. If it's right, everything works fine; but if not the signal drops to almost nothing).

arQon,

Thank you for the reply. I really appreciate the help. I ran the "lspci" command but I'm not sure what this is telling me...

00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
06:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

Is that Intel wireless with a Realtek ethernet card?

--neal

Also, I'm realizing that I'm lucky the wifi is still working at all as I am unable to connect to my router via a wired connection :confused: (I've always just connected wirelessly). I'm sure it's just a setting somewhere, but I think for safety's sake, I should probably get that straightened out once the wifi is happy again (I'll have to go see if somebody already addressed that one up here).

I think what arQon wanted was to see your result of

lspci -vvv

and snip the result to show just your ethernet and wifi
I am on a tower but will give you a clue as what it shows.....kernel module
It does not show what firmware is loaded but we can suspect the wifi is
a 3160 ucode.

here is my lspci result with snip
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 SNIPPED the junk
Kernel modules: r8169

Next

try just running

dmesg

and scroll thru to find your ethernet or wireless products and copy and paste them

also you could try
dmesg | grep firmware

for your dmesg stuff.....please do not snip any stuff related to your wifi or ethernet

Nope, just the most basic info was fine: all I was after was the manufacturer and model number: the more intricate technical details aren't actually relevant for the problem I was hoping for. :slight_smile:

@neal:

Is that Intel wireless with a Realtek ethernet card?

Unfortunately, yes. Unfortunate because it means I don't already know the magic that will fix things for you. :frowning:

The checklists for tracking down wifi problems are always intimidatingly long, and especially so on Linux. Given the fact that it USED to work though, my guess would still be "power management", which you seem to have covered already; or "antenna-related", as the top two. Laptops nearly always only wire up a single antenna, and it never ends well.

After that would be Bluetooth (if it's a combo card, which most are). Bluetooth is garbage from start to finish, often interferes with wifi, and in some hardware (and unfortunately also most software, including nearly all Linux DEs) is damn near impossible to truly turn off. (The classic case is a system requiring a reboot to actually change the state, which of course then turns it back on! :P)

This one's a stretch, but what's the output of "cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf"?

Incidentally, since the underlying issue will be either hardware or GNOME-based software, rather than MATE specifically, it would be well worth posting this on askubuntu: there's a guy there who's very good with wifi and very helpful (?something fox? perhaps? I'm not good with names), and even if he's not around there are simply a lot more people on there, one of whom may have already had and resolved this exact problem. (There's also more noise, but it's not too bad).

Kernel updates could be to blame. I was hit with degrading Wi-Fi issues when I first started using Ubuntu many years ago with a USB Wi-Fi adapter. It worked great in 11.04, 11.10/12.04 made it unusable then 12.10 fixed it. Turned out it was using a new driver, presumably from the kernel.

If you still have old kernels installed, you could use them to rule out recent kernel updates being the problem. Hold SHIFT while booting up the computer and select Advanced options for Ubuntu. From there, try booting the oldest kernel version and see if Wi-Fi works better.

Hi arQon,

Unfortunately, yes. Unfortunate because it means I don't already know the magic that will fix things for you.

Bummer. I was hoping for the magic. :wink:

This one's a stretch, but what's the output of "cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf"?

[email protected]:~$ cat /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
[connection]
wifi.powersave = 3

I'm not sure what that means. :grimacing:

Incidentally, since the underlying issue will be either hardware or GNOME-based software, rather than MATE specifically, it would be well worth posting this on askubuntu:

Thanks for that arQon. I appreciate it. I've not investigated askubuntu but will start asking over there too.

Hi lah7,

If you still have old kernels installed, you could use them to rule out recent kernel updates being the problem.

I like your thinking. I was able to back up to version 4.15.0-48-generic x86_64. Unfortunately, this does not appear to have made any improvements. :slightly_frowning_face:

Hi aus9,

I ran the lspci -vvv command you suggested and it looks like my wireless controller is, indeed, the 3160 you suspected...

06:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
Subsystem: Intel Corporation Dual Band Wireless AC 3160

Next I ran dmesg and boy does that return a lot of info! Here's what I was able to pull out of there...

[ 23.062930] Intel(R) Wireless WiFi driver for Linux
[ 23.062932] Copyright(c) 2003- 2015 Intel Corporation
[ 23.063020] iwlwifi 0000:06:00.0: enabling device (0000 -> 0002)
and
[ 23.779351] iwlwifi 0000:06:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164

I hope that's useful.

I wasn't expecting you (or almost anybody else) to be, but I am...

NM_SETTING_WIRELESS_POWERSAVE_DEFAULT (0): use the default value
NM_SETTING_WIRELESS_POWERSAVE_IGNORE (1): don't touch existing setting
NM_SETTING_WIRELESS_POWERSAVE_DISABLE (2): disable powersave
NM_SETTING_WIRELESS_POWERSAVE_ENABLE (3): enable powersave

So, yeah. Change it to 2, reboot, and see what happens. May well not make any difference, but certainly first on the list of things to try. gl. :slight_smile:

@ nmboutin
as I said I am on a tower so hope arQon can fix

in the meantime as it appears 1 day has lapsed since his reply I found someone on the net with your device.....with REV=0x164
https://www.linuxquestions.org/questions/arch-29/can't-get-wireless-to-work-4175601555/

this person.....you may have to read all of the post, did not understand the results of
sudo ifconfig

so you are unlikely to see eth0 or wlan0 but some other string.
but the suggestions unrelated to wifi antenna concern rfkill if interested
and looking to see if firmware is loading correctly

so if still faulty report
dmesg | grep iwlwifi
(and)
rfkill list all

and someone had a problem with firmware as per
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1785671

Thanks arQon. Sorry I've been away.
I had changed the etc/NetworkManager/conf.d/default-wifi-powersave-on.conf script so it always came up with wifi.powersave set to 2 by default, but changed it back to what it was when it didn't do the trick (I have this thing about leaving too many things changed). But I'll can change it back again and leave it that way. Given what it means, I think it makes more sense to leave it defaulting to 2.

I've changed it back and restarted the machine. Still, it just doesn't behave like it's actually turned off, even though it says it's off. So strange.

I think I need to rule out a possible hardware issue, so I'm going to do something I don't want to and reboot this computer in Windows 10 and see if the wifi is still weak. If it is, then I think it's got to be hardware related. I'll report back here when I see how it goes.

aus9 - Thank you for that. I checked out the link you provided and while much of the discussion is a bit over my head, I think the issue they're discussing there is a little different as I do have wifi, it's just painfully weak on this computer.

As mentioned in another reply to arQon, I'm going to eliminate the possibility of a hardware issue and reboot this thing in Windows so see how it does. If all is well with Windows (makes me cringe to think of it), then I'll keep exploring options. If it's weak in Windows, then I think it's hardware related. I'll report back soon.

Thanks!