Webcam (integrated) partially not working

Hello everybody,

I got a strange problem with my integrated webcam on my thinkpad t420. When I start the machine, cheese shows a moving picture. Everything is working as expected. When I later start the wire messenger the webcam stops working. When I then again fire cheese up, there isn't a moving picture within cheese too. Same problem with jami messenger. That's why I think it is not a problem with a specific messenger app. Also I have o shut down the pc and start it up again to get cheese working properly again.

Can anybody help me solve this problem?


Hi @laser404 :slight_smile:
I got once something similar on a t420 thinkpad.
This got solved with a reboot and never reproduced again.
If this continue occurring, you can check directly the logs :

sudo dmesg

and post here some logs :slight_smile:

[ 5.341089] uvcvideo: Found UVC 1.00 device Integrated Camera (04f2:b221)
[ 5.360982] input: Integrated Camera: Integrated C as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/input/input10
[ 5.361078] usbcore: registered new interface driver uvcvideo
[ 5.361079] USB Video Class driver (1.1.1)

Those are the most interesting lines, right?

Something similar with error messages, what went wrong :slight_smile:
Try to get those logs just after the webcam stuck.

Hi again,

well I still don't know what caused this strange behaviour but I got this solved by hammering the following lines into my keyboard:
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

I tried to use the webcam yesterday and it was working fine again :slight_smile: