Webcam not recognized

Hello,
I have an old USB digital camera/webcam (“Kidigicam”). I want to use it on my laptop with Ubuntu Mate 16.10. The laptop has its own front-end webcam which is seen as /dev/video0. While the USB device is seen by lsusb and is accessible via Caja to browse the pictures from the camera, it’s not recognized as a webcam.

Using Xubuntu 16.10 on the same laptop, the device is properly seen as /dev/video1 and usable.

Any idea as to why Ubuntu Mate doesn’t see it as /dev/video1 and if I can fix this?

EDIT: trying to install xubuntu-desktop on my main PC (which is on Ubuntu Mate 16.10 too), I see that it wants to install upstart. I’m a bit surprised, I thought that every Ubuntu flavor had switched to systemd at this point. Does it have consequences on the hardware detection and thus could explain the difference between both distros?

Hi @terzag,

I don’t have your model webcam, try taking a look here:

https://help.ubuntu.com/community/Webcam

This documentation seems to be out of date: the driver it references doesn’t seem to exist anymore.

Besides, my main issue is on the hardware side, independant of the software used, as it isn’t even recognized as a video device (no /dev/videoX).

As it’s supposed to be handled by the kernel, I don’t understand why it is seen on Xubuntu and not Ubuntu Mate with the same version (and thus, the same kernel and modules − in theory at least). Doesn’t Ubuntu Mate load the same modules?

If I try to rmmod uvcvideo (on Ubuntu Mate), it says the module isn’t loaded, and it doesn’t change anything when loading it with modprobe. I’m not sure if its still uvcvideo that handles the webcams these days. Anybody knows?

EDIT: here is the output of dmesg when plugging the webcam on both distros:

MATE
usb 1-2.3: new full-speed USB device number 10 using ehci-pci
usb 1-2.3: New USB device found, idVendor=2770, idProduct=9120
usb 1-2.3: New USB device strings: Mfr=0, Product=2, SerialNumber=0
usb 1-2.3: Product: USB DIGITAL STILL CAMERA
gspca_main: sq905-2.14.0 probing 2770:9120
gspca_main: sq905-2.14.0 probing 2770:9120

XFCE
usb 5-2: new full-speed USB device number 2 using ehci-pci
usb 5-2: New USB device found, idVendor=2770, idProduct=9120
usb 5-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
usb 5-2: Product: USB DIGITAL STILL CAMERA
gspca_main: v2.14.0 registered
gspca_main: sq905-2.14.0 probing 2770:9120
usbcore: registered new interface driver sq905

I notice two thing: on Mate, the webcam is apparently probed twice and on Xfce, a new interface is registered, which is not the case on Mate. I assume this might be the issue?

HI @terzag,

I don’t know about the settings for webcams?, what I want to ask is; is your webcam old and is it a USB 1 device?, have you tried changing the USB port for the camera to see if it being wrongly addressed by the system?. :smiley:

It’s an old low cost crappy webcam, I have no idea if it’s USB1 but it’s highly probable. Changing the USB port makes no difference.

EDIT: I’ve just made a test which is quite interesting. So far, I had Ubuntu Mate installed on both my main PC and laptop, and I was trying Xubuntu as LiveCD on the laptop for conducting tests. I’ve just (re)installed Xubuntu on my main PC alongside Mate to do tests more easily by switching between the sessions.

So now, I can add that the issue doesn’t seem to come from a missing package or module but is related to the session. On the same PC, plugging the webcam on Mate doesnt work, plugging it on Xfce creates /dev/video0 and it is recognized.
So, what the hell happens in the Mate session that makes it unable to setup this webcam? I have to note that when plugging it on Mate, it recognizes it as a digital camera, as I’m asked if I want to open it with Shotwell. On Xfce, nothing happens from Thunar: the device appears on the desktop as a digital camera but it doesn’t trigger Thunar. So I wonder if it would be Caja or something badly recognizing and mounting it…

I have another similar crappy webcam (different model and manufacturer), I’ll check if it does the same thing.

EDIT: ok, same behaviour and I’ve found the origin of the issue: when one of my webcams is plugged, it is mounted by Caja as a digital camera and isn’t seen by the system as a webcam. As soon as I unmount it in Caja (eject icon), /dev/videoX is created and the webcam is usable.

So, I’m not sure if it’s a bug or a feature and if it applies to all USB webcams or only those that are hybrid of still camera/webcam.

Anybody has an USB webcam and can check its behaviour on Ubuntu Mate?

Hi @terzag,

I have a Logitec USB camera and have no problems with it under Mate!. :smiley:

I guess it’s only a webcam, it’s doesn’t allow you to take still pictures and doesn’t appear in Caja as a storage device?

It depends on what app you are using, you can take stills (photos) with Cheese for example!. :smiley:

Sure but I meant without software, i.e. with a button on the cam itself. What I’m trying to understand is if regular USB webcams are seen as a digital cameras or if it’s only with peculiar hybrid hardware.

1 Like

Ah!, now I understand you . I think that you won’t be able to get around it that easy as I think the command line way would still require an app to be installed?.

The link below may/may not be of help to you?:

There is a button on my Logitec webcam but it doesn’t do anything in Linux!. :confused:

Maybe one of these might prove useful to you?:

https://filmora.wondershare.com/video-editing-tips/screen-capture-tools-for-linux.html

I’m not trying to take still pictures with the device. :wink:

Let’s recap: I have two old crappy hybrids of digital camera/webcam. One is a “Kidigicam” (not related to the KDE Digikam software), the other is an Aiptek Pencam. Basically, they’re digital cameras that allow to take a few pictures in incredible resolutions like 320 × 240 or 640 × 480 − the latter being considered “hires”, you can imagine that they’re not top-notch nor recent equipment, they’re the kind of stuff you got for 20 bucks 15-20 years ago. They have a button to take pics when not plugged to a PC and save them in their internal memory. They can also work in webcam mode when plugged to a computer. When it’s the case on Ubuntu Mate, they’re mounted by Caja as digital cameras to access the pics from their memory (which is my main issue, as they’re then unavailable as webcams until they’re unmounted). As I’ve never had a proper webcam, I was wondering if all USB webcams were handled that way or if this was something specific to this kind of device.

Basically, I’m trying to gather information to know if it’s worth filing a bug report or if it’s a normal behaviour that they automount and are then unrecognized as webcams.

1 Like

HI @terzag,

sorry but I’ve got a cold (a poor excuse if ever there was one!), I cannot find anything anywhere on the web relating to your problem, it may just be that the webcams are so old that they just won’t work correctly with Linux but I really don’t know or have an answer for you!. :frowning:

Maybe spend a few Dollars/Euros/Pesos and buy a newer one, they don’t cost the Earth!. :thumbsup:

I would go with a later Logitech model!:

http://www.logitech.com/en-us/video/webcams

it may just be that the webcams are so old that they just won't work correctly with Linux

Oh, they work fine, it's just that I'd like Caja not to automount them as digital cameras. :wink:

Maybe spend a few Dollars/Euros/Pesos and buy a newer one, they don't cost the Earth!

I don't really need one, it was rather that I had these two in a box and figured that instead of letting them rot, I would as well try to use them (at least the Kidigicam, which is not too awful on the image quality) and wondered why they behave differently between Ubuntu Mate and Xubuntu. So, that's not a big deal, it would just be better if it worked flawlessly; and just in case it's a bug, it might be useful to report it.

1 Like