Welcome doesn't work

Installed 18.04 Beta to try it and Welcome can’t be launched
Another way to do it then by the menu Icon ?



Come on Watford! Control Center, Welcome. Steady on.

1 Like

saw it done that
by control center, by menu list…nothing zip
Same for the Software boutique

Will reboot, reinstall and what not and will come back


p.s. just got an error msg…seems to be a ‘seed’ problem…related ?

Good luck Watford. You might also try seeing if your shasums match.

Sha256sum does match

Hi Watford,

I had the same problem, I ran updates and it fixed it!:

Ubuntu Mate Update Guide :smiley:

What’s the error when you run them via the terminal?


I reinstalled from the ISO to the USB for a re-install.
Welcome and software boutique do not launch while calling them from the USB itself.
Normal ? Maybe this is what is replicated on the install ?

If I recall the 17.10 Welcome was available when using the USB…
Or do I miss something basic ?


I did the following in terminal:
[email protected]:~$ ubuntu-mate-welcome

Command ‘ubuntu-mate-welcome’ not found, but can be installed as:

sudo snap install ubuntu-mate-welcome

[email protected]:~$ sudo snap install ubuntu-mate-welcome
[sudo] wachtwoord voor rene:
error: This revision of snap “ubuntu-mate-welcome” was published using classic
confinement and thus may perform arbitrary system changes outside of the
security sandbox that snaps are usually confined to, which may put your
system at risk.

   If you understand and want to proceed repeat the command including

[email protected]:~$ sudo snap install ubuntu-mate-welcome --classic
ubuntu-mate-welcome 17.10.16-e5080a8 from ‘flexiondotorg’ installed

Now Welcome is working fine