Welcome not working on Mac PPC 16.04


A recent update installed Welcome for 17.10 on my Mac PPC running 16.04. It no longer works. I get a white screen. Clicking on the white screen yields a black screen. Is there any way to return to Welcome for 16.04?

UM Welcome not working in UM 17.10 beta 1 32 bit

The following two links should help.




I do not know of a toggle that does not use Welcome itself. I have removed Welcome using apt in terminal.


Thanks, steven, for this information. By nosing around with Synaptic, I was able to choose the older 16.04 version and reinstall it. It seems to be working. I have tried locking it so it will not update to a version that does not work.


Does anyone know how to keep Welcome from updating itself even after a version has been locked in Synaptic?


What would happen if you unchecked the references to welcome in Other Software?


The screen shot you posted appears to be from Software Update. Software Update appears to honor the Synaptic choice to lock Welcome. The problem I have is from calling on Software Boutique from within Welcome. Software Boutique updated Welcome to the unusable version for 17.10 causing me to have to remove it with apt and reinstall the older version for 16.04 using Synaptic.


OK, I was assuming that since Welcome is a PPA, and therefor not downloaded from a repository, disabling the source from which Welcome is updated from, would prevent it from updating.


Your suggestion of unchecking references to welcome in Software Update works. Thanks.


To summarize:

(1) Remove the nonworking Welcome in Terminal using apt:
sudo apt remove ubuntu-mate-welcome

(2) Using Synaptic, install the older version and lock it.
In Synaptic, search for welcome and select it. In the Package menu, select Force Version to go back to the 16.04 version.
After installation, lock the version (also under Package menu).

(3) Open Software Updater and under Settings choose Other Software and uncheck the references to welcome.


Newer versions of Welcome (through the updates PPA) use a newer library called WebKit2, which has been known to have problems under PowerPC, unfortunately.


With steven’s most valuable help, I have the 16.04 version working properly again–see reply 10.


Thank you @lah7. I previously knew Welcome now included WebKit2, but I could not recall the name yesterday. Had me scratching my brain… :relieved:


Glad you found a solution to you inquiry @tomi, and thank you for including a summarization of the steps you took. Please mark your post as solved to help other find a solution in the future.