Whoa! 16.10 Themes Kill Keyboard Navigators!

Let me first describe what I’m talking about…

Bring up the shutdown dialog with Ctrl+Alt+Delete. Make sure it has focus (a separate Marco problem for another time). Press TAB to select (highlight) the button you want then press ENTER to do it.

Many 16.10 themes have made the highlighting soooo subtle, you can’t tell selection at all! Some themes like GreenLaguna are ok. TraditionalOK actually does bold the letters slightly but I need to zoom in to see it.

I notice TraditionalOK in Mate 1.12.1 and 1.14.1 changes the button color for highlighting which works great but it’s totally gone in 16.10.

I know mouse clickers will never care or notice and us keyboard navigators are a dieing breed but geeze… When it kills function so completely I have to say sompin’. :rage:

All Comments Welcomed

1 Like

I run GreenLaguna so this is something I have not experience. But yes, I can see this being annoying and in need of a fix.

Kinda reminds me of the Ambiant MATE scrollbars in MATE terminal where it is really hard to tell the slider from the background.

@maximuscore Yes! I’ve seen some rather confusing scroll bars. A classic case of those used to it no longer see the problem.

@anon42388993 lucky dog! GreenLaguna is probably the best of the few without the issue.

For me, control highlighting in 16.10 is an absolute show-stopper so I really want to emphasize the issue and refer to this demonstration in the future.

Here is the shutdown screen when tabbing between buttons on Mate 1.14.1 vs. 1.16.0 (Ubuntu-Mate 16.04 vs. 16.10):

Believe it or not, they are tabbing between the same buttons at the same time. If you look closely, you can see how 1.16.0 has a very subtle darkening of the font but otherwise near-useless highlighting. My normal screen resolution puts it around the limit of perception.

I'm always keen to a workaround. Anyone have any pointers how to edit such settings in /usr/share/themes? It may be an easy fix.


Whoa, that is indeed quite broken. I actually had to zoom in to even notice any change on the GTK3 dialog.

1 Like

Hi @maximuscore and thanks for the confirm. I use compiz zoom to see it, too, but I’m wondering how monitor characteristics might affect how others see it.

I realize all the themes were converted to gtk3 and general appearance matches quite good, and may have been a major effort. That’s “TraditionalOK”, BTW.

I’ll bet it’s as simple as highlighting had little or no priority to end up this broken. I’d gladly put in some time for it but it’s not at all obvious how to tweak gtk3 themes. Anyone?

It’s is a theme bug. It. Is being fixed upstream.

Much appreciated, @Wimpy. Constant use of 1.16 shows very few dialogs are actually involved but I’m sure glad it’s being fixed.