Why can i not get any higher internet speed than 50meg on ubuntu mate?

i cannot get any more than 50 meg on ubuntu? i have 200mb connection but in terminal/browser i can only reach 50mb at best. on windows i hit 198-206mg. is there something im missing?

Hi
You need to provide more information.

Is this a cable or a wireless connection?
What procedure are you using to test the speed?

Please post the output of:

inxi -N

[email protected]:~$ inxi -N
Network: Card-1: Qualcomm Atheros AR8162 Fast Ethernet driver: alx
Card-2: Realtek RTL8188EE Wireless Network Adapter
driver: rtl8188ee

im am using hard wired connection to router.

speed is identical on wifi also.

Are you using Virgin Media? Because, if you are, they are throttling Linux. I have exactly this problem and I have been onto Virgin who, naturally, deny all of it. Meanwhile, on their forums, I have posted about this and there are many others who are experiencing the same issue.

I have got round it by having a scabby old notepad with MS Windows on it with a wi fi connection to the hub. Then, I have this notepad share its internet connection by ethernet cable with my Linux rig. Because the hub “thinks” it’s only an MS Windows machine that is connected, it gives full speed on the connection, indirectly, to my Linux rig.

It’s pretty disgusting that I have to do this. But, there it is. I have 6 months left on my contract, at which point I am changing ISP. I never had this problem with Sky broadband.

1 Like

i am on mid continent, only provider with that speed, i test it on speedtest.net, pretty sad if they are throttleing it because i use linux. I’m sorry i hate windows, but last time i checked that’s called freedom of choice… all i want is my speed. no reason to throttle when all i do is my job in linux…

the question remians, i brought in a windows computer and it hit 204.79mb. with the tech on the phone she watched on her end and saw the difference. im still at 51.49 meg on ubuntu mate. is there something i need to change or is insufficient in or on my computer? here is the info:
[email protected]:~$ inxi
CPU~Dual core Intel Core i3-3110M (-HT-MCP-) speed/max~1200/2400 MHz Kernel~4.4.0-38-generic x86_64 Up~1:09 Mem~807.9/5849.8MB HDD~1000.2GB(4.9% used) Procs~208 Client~Shell inxi~2.2.35
[email protected]:~$ inxi-n
inxi-n: command not found
[email protected]:~$ inxi -N
Network: Card-1: Qualcomm Atheros AR8162 Fast Ethernet driver: alx
Card-2: Realtek RTL8188EE Wireless Network Adapter
driver: rtl8188ee
[email protected]:~$

any help would be greatly appreciated. we also tested with firewall on and off, speed was the same.

It’s not just Ubuntu mate. It is any linux distro. I have tested a number of them.