Why does apt update/upgrade break GUI in PPC MATE 14.04?


Posted this issue as part of the “Testers wanted for PPC Ubuntu MATE” thread in the “Apple Hardware Users” Ubuntu sub-forum, where another poster Luigi reported this problem two weeks ago there, so there are at least two of us that were having some busted system problems after doing an update/upgrade . . . and that is what might also happened to my iBook MATE 14 PPC edition.

I did a kernel upgrade and a bunch of other stuff last weekend, using aptitude through the terminal, and saw a bunch of stuff to be removed, “marco” “mate-screensaver” . . . and a kernel upgrade, and I clicked “yes” . . . ran thru that, and then can’t remember if I rebooted to check the system or just went to OSX (for the “suspend” that 14.04 PPC doesn’t have).

Today/yesterday now, restarted, got to the MATE log in window, logged in . . . and only the MATE desktop image is working, no toolbars, nothing else, nada . . . . Jumped to a TTY and ran the update/upgrade and again 80MB worth of stuff, FF, TBird . . . few other things . . . screen went black . . . waited until the machine stopped making noise, rebooted . . . this time hit the “tab” key and booted “Linux old” . . . same thing, logged into the desktop image . . . only . . . no icons, no panels . . . just the MATE theme desktop image and mouse pointer moves around.

This is first time in recent or distant memory that an ubuntu upgrade has busted the system in a fairly substantial way . . . . Obviously I can access the CLI, but, no GUI . . . . Haven’t had time to try to install another DE and see if that runs or not, but might get there in a couple days . . . . I’ve filed a bug report 1440266

I’m wondering if I can get some feedback on possible causes of this breakdown before I proceed to spend time trying to fix something that perhaps is not broken . . . . Also can’t tell if link to LP bug report “worked” but, it’s bug # 1440266 That was filed a day ago . . . .




start your PC in "Recovery Mode" and click on "Network", then run DPKG (Network cable required) and see if that fixes the problem. Reboot using Ctrl + Alt + Del (do not click on "Resume").

If that fails after a reboot, go back into recovery mode, activate network again and then go to "root" and type the following command:

sudo dpkg --configure -a && sudo apt-get update && sudo apt-get install -f

You can type that as one command as above or do the following:

sudo dpkg --configure -a

sudo apt-get update

sudo apt-get install -f

Then reboot again using Ctrl + Alt + Del (do not click on "Resume").

See the update guide for more info:

Hope it helps. :smiley:


Appreciate the reply and the suggestions . . . however, in PPC or at least
in my case I don’t have GRUB/recovery mode . . . we/I just have Yaboot . .
. I don’t know if Yaboot offers “recovery” . . . . I guess I could check
that. But by clicking “network” . . . it seems like you are thinking that
network is not connected???

Also, I more or less know that “dpkg” . . . repairs packages?? that are
broken?? Running update/upgrade through the Terminal two times recently,
the first which was showing a number of packages to remove, “marco” and
“mate-screensaver” . . . and then a few days later . . . didn’t show me any
“run dpkg configure -a” errors that I’m aware of . . . I have seen that
historically. And, then I ran “autoremove” last night . . . and then
installed XFCE4 which I’m using now to type this . . . .??? Meaning a
number of times that “dpkg” could or should have been run via aptitude,
no? And, I have restarted after each of those upgrades . . . .

I guess no harm in running the suggested commands in Terminal . . . . I’ll
post back if anything changes . . . fairly significant bustage of system .
. . . Appreciate the thoughts . . . seems like so far no response on the
LP Bugz.


[edit: Ran thoose suggestions from Terminal, logged in the GUI using XFCE session. Ran as “sudo” and then as root . . . runs through the list of update repositories, nothing about “dpkg” . . . and then shows “0 upgraded, 0 newly installed, 2 packages held back” . . . so I ran it as “dist-upgrade” and can’t get those 2 packages to install. They are “libvte-common” & “mate-terminal-common” . . . . Rebooted from Terminal and logged into MATE session to a nice clean black screen with a moving white mouse cursor . . . no toolbars, no icons can be seen in the blackness. Rebooted from TTY and back in XFCE session.]


well I cannot really comment on your install as I don't do the PPC thing!.

I must ask you though, how did you install your system, via a disk or USB install and did you follow this advice? (I know you are smart enough to know this but I must ask anyway!):

Other than what I have already told you, I'm out of ideas if your terminal is not working; I have nothing except a complete fresh install to offer you!. :smiley:


Right, there is always “nuke n pave” . . . which is what I usually do
as the “work around” solution if nothing else is offered. But, just in
reply to your last email–“Terminal” is working–either in the TTY, or now
in XFCE session . . . so I don’t need to hold my breath for a fix. I’ve
“fixed it” by installing XFCE using “MATE theme.” I’m just wondering about
the why of it, why did an aptitude upgrade seemingly break the GUI MATE
session? Seems like there was a substantial “revamping” of the MATE DE
with kernel upgrade and rm-ing “marco,” but then apparently not enough
material put back to load the GUI?

It’s a bit “odd” . . . but, other things to do before doing a fresh
install, which, yes, the DVD that I installed from was burned at slowest
speed, and that was perhaps back in Jan, with at least a couple kernel
upgrades in the interim, along with numerous regular “upgrades” . . . all
went well until the upgrade last weekend.

Only “clue” so far has been the cryptic suggestion from the other fellow
who experienced this problem on the Ubuntu forum to, “newer do partial
update”–with no follow-up commentary after that. I’m assuming he means
“never do partial update” . . . but, what would that mean, only do fresh
installs each time? Doesn’t make sense in terms of the “standard of care
and feeding of the linux system” . . . as far as the regular use of “apt
update/upgrade” . . . .

One thing I’ve lost track of is whether I’m still in 14.04.1 or whether the
14.04.2 upgrade has been made . . . and whether that would happen
“automatically” with dist-upgrade or has to be done manually??? Like I
said, now only two upgrades are “held back” . . . one of them a
“libvte-common” the other “mate-terminal-common” . . . . no kernels or
“headers” listed, etc. Off to celebrate the holiday . . . .



I just took a look at known issues with PPC 14.04 and there doesn’t seem to be anything about updates causing a system screw-up!:


So, what are your software sources download location settings like, do you have them set to “Main”?. I would always choose that first over any other download source!. :smiley:

Can you get Synaptic up and running?, if so, search for this package: “mate-desktop-environment”, right click it and mark for “Reinstallation”, apply that and then restart, see if that helps!. :smiley:

Also, when you run dist-upgrade, bung a “-f” on the end and it will force any missing dependencies!.

sudo apt-get update && sudo apt-get dist-upgrade -f


Thanks for the added thoughts, about out of time today on this one, but I
should have synaptic available in XFCE, so I can check that, as well as the
“-f” thing . . . probably going to be a couple days before I can get back
to it. I’ll post back after I’ve looked into these ideas . . . .


On Sun, Apr 5, 2015 at 12:45 PM, wolfman [email protected] wrote:

So, what are your software sources download location settings like, do
you have them set to "Main"?. I would always choose that first over any
other download source!. [image: smiley]

Can you get Synaptic up and running?, if so, search for this package: "
mate-desktop-environment", right click it and mark for
, apply that and then restart, see if that helps!. [image:


Sources are set for "main" . . . tried to check synaptic, had to use the
Terminal to launch it. Checked for "mate-desktop-environment" . . . it
showed it was "not installed" so I couldn't mark it for "re-installation" .
. . when I marked it for install, it suggested other dependencies . . .
then the "apply" icon didn't highlight, and an exclamation point was now
next to Mate-desktop-environment!! Checking what that meant it showed
"broken" as status??? A couple other mate items are shown as installed
"pluma" "mate themes" a few others. System with MATE was working fine, now
something seems to have broken it. Also when I launched synaptic via
Terminal an error window showed a "GTK message: Failed to load
canberra-gtk-module" ??? Does that mean anything?


Hi e_e_P_,

read here about "Failed to load canberra-gtk-module":

If you can't click on the "Apply" icon, this may be due to the version of Synaptic, try removing Synaptic and re-installing it via the terminal with the following command:

sudo apt-get remove synaptic && sudo apt-get update && sudo apt-get install synaptic

Other than that, I reckon you have a corrupt install due to all the various errors you have, did you try this command?:

sudo apt-get update && sudo apt-get install -f

The above command should (under normal circumstances) fix a broken install!.

If you used a disk to install, hold it up to the light and see if there are any pinpricks of light showing through, if there are, there is your culprit!. Throw it away or use it as a coffee coaster!.

Hope it helps. :smiley:


Appreciate the replies, didn’t have time to check the “canberra” thing, but
the replies aren’t too helpful, there, as I have 32 bit PPC.

So, ran the suggested commands and got at the end of the a-g install -f
command, meaning nothing seemed to have been found or fixed:

"Reading package lists… Done
W: Failed to fetch

W: Failed to fetch
Unable to connect to

W: Some index files failed to download. They have been ignored, or old ones
used instead.
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded." I also got
“Unable to LoUbuntuMATE ROM” error in the splash before the log in window.
This “failed to fetch http//127” error has I think been happening for a
while and no problems. I’ve exchanged the synaptic so I’m going to test
that now. It does seem like somehow something has become corrupted . . .
that much is fairly clear. I’ll post back with the results of the new


Top posting: Synaptic foound broken packages that it couldn’t repair:

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused
by held packages.
E: Unable to correct dependencies
E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused
by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused
by held packages.
E: Unable to correct dependencies

I’ve exchanged the synaptic so I’m going to test that now. It does seem
like somehow something has become corrupted . . . that much is fairly
clear. I’ll post back with the results of the new synaptic.


looks like you had network failure there also to add to your troubles!. :disappointed:


A brief network failure? Don't know, all the rest of the sources list seems to go through OK, and up until recently it hasn't created any problems for update/upgrade. But, spent some time trying to get synaptic to do its thing, like I said, I have to "su" in Terminal to open synaptic, otherwise it says I have "no admin privileges" . . . but, I'm just in another session, logged in as me . . . so there is some significant "corruption" and also FF doesn't remember "previous sessions" . . . . Anyway, I came up with the idea to use synaptic to "remove all MATE" things . . . but as I was scrolling through the list of MATE stuff the two mate terminal apps? mate-terminal & mate-terminal-common . . . both had exclamation points in front of them, so then I decided to try to just remove them and see if that "fixed" the problem, but, couldn't remove one of them because it was "broken" . . . so I fixed it, and then removed them and also apport (which I just recently had to install to try to report to Bug reports) was removed, also "libtve9"??? was removed today. Then when I tried to "install" mate-terminal-common" it said "failure due to dependency, need libtve9, but we aren't going to install it" . . . . so, I think I just installed mate-terminal via synaptic . . . rebooted, tried to log in via MATE, back to the black screen . . . . So, point being that until today when I ran "dist-upgrade" "two packages have been held back" . . . the libtve-common and the mate-terminal . . . and I was pursuing this idea that one of those packages was "corrupted" . . . . BUt, then it was odd that now libtve9 is "needed" but, was just removed via aptitude . . . . I'm away from the unit now for a few hours, don't know if anything is going to appear in a flash . . . or, I just have to decide which system I will "nuke and pave into" . . . . I guess if I could find a U-MATE 14.04.2 PPC iso it might be worth trying . . . . System is sort of OK using XFCE, except that I don't seem to be "admin" & FF doesn't remember where its been . . . .

Thanks for the attention . . . somebody to bounce stuff off of is helpful . . . .



did you check the disk for defects?.

Did you try changing your software sources download location to something else rather than sticking to my suggestion about using “Main”?.

Did you take your headache tablets today!. :smiley: :smiley: :smiley:

@wolfman: I did check the disk and SMARTReporter in OSX says disk is OK. Hopefully you understand that this appears to be a software side problem? I tried again to “re-install” mate-desktop-environment in synaptic, after running “dist-upgrade -f” a little earlier. After the “dist-upgrade” there were 15 packages to download, and 3 to remove, noticed that one of the ones to be removed was “libvte-common” . . . which was just iinstalled yesterday?

Also, in synaptic, although I believe I just tried to remove and reinstall “mate-terminal” which showed an exclamation point, today, “mate-desktop-environment” showed as “not installed” . . . when I checked it for install there was also an exclamation . . . just like yesterday when I clicked “repair broken packages” there is an error . . . due to “dependencies” . . . yesterday it was “no libvte9”??? Today I checked in synaptic and 'libvte9" is available to install . . . but didn’t seem to show up when checking “mate-desktop-environment” . . . .

Ah, yeah, after doing the dist-upgrade I tried to log into the MATE session, the background image was back again, yesterday it was just blackness . . . no toolbar, etc. Might make “sense” knowing that there is apparently now, no “mate-desktop-environment” installed. Also looking thru the “properties” on the error install of mate-desktop under “versions”?? it showed two, one was a something1.8.0 +9 (trusty1) and the other was an earlier 1.8.0+8~ppal Trusty1( . . . which may explain that ( “failed to connect”??? As it is an earlier version??? The numerous problems continue with needing to “su” in Terminal to open synaptic, and FF not rememebering passwords or history . . . in the XFCE session, etc.



I think you are basically wasting your time as you have tried everything and it "ain't gonna happen", I would do a complete fresh install starting completely from scratch!.

I don't have anything else for you unfortunately!. :cry:

Also, see Steve's answer here, it might mean something to you?:


For whom the bell tolls? It tolls for thy install of U-MATE . . . .
Thanks for providing the “last rights” . . . I was trying to avoid a fresh
install, since this install is only a couple of months old . . . and had to
do a little tweaking to get it running . . . . But, it does seem like the
“corruption” is bleeding over into the XFCE session . . . making it just
about “not useful” as a system . . . . I was looking to see if there is a
U-MATE 14.04.2 PPC iso that could be freshly downloaded, but still looks
like 14.04.1 is the extant version.

Does it make sense to try a fresh install of the install disk that I used
in Jan? Or, get a fresh download of 14.04.1 and possibly that would be
“different”? I’m on the line about just moving on to another option like
now only Lubuntu is supporting PPC out of the box . . . trying that until
it blows up, etc . . . or doing a fresh download of “Ubuntu Core 14.04.2”
for PPC and then try to add “mate” DE on top . . . and see if that brings
it “back to the land of the living”???

Appreciate the thoughts,


Hi e____,

go for a new ISO and mark the other disk with a "?" mark.

here's the link from the Ubuntu Mate website!.

Set your software sources download location to "Main"!. :smiley:

Good luck!. :smiley:


OK, thanks for the response and the link . . . I’ll look into it. I did
read the other thread that you had linked, it didn’t show up in the Gmail
copy I replied from . . . the one where they were talking about the issues
with “meta-packages” . . . in 14.04, and that may be what’s going on, with
aptitude not able to “figure out” how to deal with the problems . . . which
may have been “solved” in 15.04 . . . problem is in PPC 15.04 is a tad
“rough” when I tried out some beta’s . . . seems like other people are
still reporting issues with Vivid in PPC, and it isn’t LTS . . . . But,
now, in terms of this meta thingie, don’t know if that is going to be fixed
by doing fresh install of the same thing . . . .

I’ll post back if and when I’ve done something . . . and then if and when
something changes . . . .


Hi e___,

don’t forget to install this package after your new install and updating!:

sudo apt-get install mate-desktop-environment