Why does this status-less terminal window will not close itself on desktop?

Hello,

Am running Ubuntu MATE 16.04 but have also ran into this issue in the past simply running Ubuntu. What happened is: I pressed a key and now I am stuck with a terminal screen that will not go away (in MATE Desktop). I would further add that this terminal screen does NOT have any close buttons nor can I resize/move it using my mouse.

This is fairly annoying as pressing CTRL+D to close it just refreshes the CLI prompt and this spawns on my 2 desktops. The only positive thing that I was able to do was unmaximize it using F11.

A note worthy to mention is that my default terminal is Terminator and that instance I am having trouble with is NOT it (Hence it wasn’t started using CTRL+ALT+T).

I feel kind of stupid having to logoff to fix this, did anybody ever ran into that issue and was able to fix it?

Thanks,

DLS

PS: I would add a screenshot but it seems that I am also too dumb to figure out how to attach one :slight_smile:

It's Tilda.

You should be able to get it to go away by pressing F1 key.

If you don't want Tilda, go to System!Preferences!Personal!Startup Applications and uncheck the box for Tilda.

2 Likes

If you’re on 16.10, there is also an option in MATE Tweak which allows you to disable the “pull-down terminal”.

Thanks a bunch guys for your useful replies.

So (re)pressing F1 didn’t worked out for me, I had to kill the PID of Tilda.

That being said, I much appreciate now having it disabled as it’s always brought me more frustrations than none.

Cheers,

PS: How do we close this thread now?

1 Like

I'm not a fan of the pull-down terminal either. It's always a CTRL+ALT+T away.

No need - I marked @Dave_Barnes' answer as the solution. (The green tick that's hiding in the 3 dots)

1 Like