Why I quit Ubuntu AGAIN :*( Mouse wheel scroll speed )

Mouse. Wheel. Scroll. Speed. Too. Fast. NO. EASY. FIX.

Or any comprehensive fix at all.

Google for hours. Entertain that maybe I am an idiot after all.

Cobbled together fixes for Chrome and Firefox. Utilities that sort of work then don't.

What utter nonsense. With the level of hardware support nowadays, how can the scroll wheel of this mainstream Microsoft mouse not be controlled in any way with any standard GUI system utility?

There's not one developer who uses a mouse wheel?

Feel the anger. Breathe. Let it go. Dump Ubuntu in the trash and walk away for another couple of years.


Maybe all the devs use a Logitech RX-250 and thus don’t have this problem… :wink:
But seriously, this is one of those annoyances that really should have been taken care of ages ago, because we’re really dealing with the basics here.
The post and comments at https://blogs.gnome.org/felipeborges/new-mouse-panel/ kinda speak volumes. No response from the developer for those asking for that feature…

So I’d say, this is definitely worth adding to Ubuntu MATE (or any Linux distro, for that matter).
I kindof wonder why it is like that. Is there some weird quirk in X11 that makes this crazy hard to implement and no one bothers to fix it? Or are indeed all devs just using mice which have a sane mousewheel scroll speed by default?


try Wiki How

maybe it should tell you how or i dont know … i m newbie man … just started today that what i do on website i have more look many information , i ain’t pro…

– Z

1 Like

A long time ago I would have done that, but I am remain an intermediate-ish user with little interest in scripting, writing drivers, or digging into the kernel.

Enjoy Ubuntu! I still absolutely love it and Linux. Just need a break. :wink:


Hi, unfortunately this is not a gui solution but I hope this will help you.

open the terminal and type the following

xinput --list

this will show you input devices of your system.
touch-pad, mouse and etc.
in my case it is PixArt USB Optical Mouse with id=13

than enter the following

xinput --list-props "PixArt USB Optical Mouse"

Please in your case, write the name of your mouse.
then there should be all the properties that you have for your mouse, can you please give the output of it here?

You can also use the id instead of the name for --list-props.

yes, but sometimes id changes.
for example if I use it for configuring the touchpad, depending on ig mouse enabaled or not, touch-pad’s id is changing

I feel absolutely the same. I'm not only quitting ubuntu, I'm quitting linux. I gave linux so many chances (mainly because I absolutely hate that windows 10 forces automatic updates), but still windows is way more usable than any linux distro that I've ever used and to be honest I don't feel like linux is faster. So done

Of course its more usable, its more compatible with everything because its the most used OS and most companies are making sure their stuff works with it. Linux isnt some magic bullet that can do anything. Its a tool, and it requires you to be an relatively proficient to use that tool correctly. There is no way around that.


Looks like I'm quitting Ubuntu after using it since 2006 (06.06, they delayed release for two months to get it right, IMHO its been very slowly downhill ever since).

Tried installing Ubuntu-Mate 20.04 on an ASUS FX705GM laptop (i7 Coffee-Lake) that had been running 16.04 since I got it over a year ago. Mate16 installed without issue although I had to use a USB mouse since the installer didn't recognize the multi-touchpad. I've had only one major annoyance and two issues with it.

The annoyance, I use a 43" 4K monitor at 3840x2160 and external USB mouse/keyboard with it and the lid closed. If I turn off the monitor all my windows are automatically positioned for the closed 1920x1080 screen. When I turn the monitor back on their locations are all messed up on the big screen.

The problems. Never could get the built-in microphone to work. Other problem with the laptop lid closed if I try to reboot or shutdown it just logs out. I have to log back in, open the laptop lid and then reboot.

My trial of 20.04 on this machine has been without a doubt my worst Linux experience yet! I always do "try without installing" to get an idea of if to proceed or not. I should have just stopped there and maybe wait for 22.04, but I persisted. Managed to get it installed booting directly into the installer with 'safe graphics". At first it looked like it might be OK, but I quickly discovered serious issues.

FIrst still no acknowledgement of the existence of the built in mic. Worse it appears to be random if the mouse/keyboard will work on boot, which means a lot of "hard" power offs! The weirdness with not being able to shutdown or reboot with the lid closed persists. The scrambling of windows when I power down the monitor may or may not be there because if I power down the external monitor, it crashes the system! I've applied all updates including the ones for today and still its not a viable system. Seems to function fine once I manage to have it boot with working mouse/keyboard (I've installed Chrome VLC and a lot of stuff from the Boutique and it all seems to function OK) but what good is a computer that crashes if the monitor is turned off and may need multiple hard power offs to get a working mouse/keyboard after a reboot or shutdown.

I just booted Manjnro-Mate live session. Unbelievable, found my microphone, recorded a video with sound in Cheese and played it back in vlc, enabled the 4K display -- the live CD is very usable.

Rebooted, let it go into my Ubuntu-Mate install and guess what, mouse worked for about 20 seconds then system locked up! After this final hard powerdown looks like I'm leaving Ubuntu. Very disappointing to see this poor hardware support on a system that worked with a only few quirks on 16.04

The Ubuntu-mate "try without installing" worked fine on my i7-6700K desktop system, but I can't mess with this until many third party tools I depend on are updated to work with Python 3.8

Manjaro has wiped Ubuntu Mate 20.04 and is applying updates as I type this.

Looks like the Manjaro honeymoon is over quickly. Despite all the hardware working correctly out of the box with zero hassles, Manjaro uses Wayland, Wayland don't work with Nvidia drivers, I need Nvidia drivers for CUDA, game over :frowning:

So figured I'd put Mate 20.04 back on the NVMe drive, install grub customizer and make 16.04 my default boot again while waiting and hoping for a fix.

Searched again for a BIOS update, didn't find one earlier -- got an ASUS site with a "dropdown" for "model" but it didn't have my fx705gm listed. This time Google gave me a different ASUS site that had an upgraded BIOS so I installed it before re-installing Mate20, but other than the version number in the setup, there were no differences in any of the settings or options (very limited) :frowning:

The new BIOS didn't fix the failure of "Try Without Installing" to run, but I repeated the installation booting directly into the installer with "safe graphics". Seems dumb luck was on my side, as I forgot to unplug the external monitor during the installation, now the system is usable!

So far, the mouse/trackpad has never failed to work after a reboot.

Still doesn't find the microphone or work with the internal speakers, although I can get sound output via the HDMI and external monitor.

Still a few glitches in display handling. Like with Mate 16, if I don't open the lid to reboot/shutdown it logs out instead of shutting down or rebooting. But if I power off the external monitor the system doesn't crash! Still annoying that when I power the monitor back on its back to "Same Image All Displays" mode, but with Display in the menubar panel its tolerable, and unlike Mate16 it hasn't repositioned all my windows to the 1080p screen size.

Before trying Manjaro, I tried straight Ubuntu and "Try Without Installing" still crashed. For me, this is the worst Ubuntu installer ever. Obviously it seems to work for most folks, and "Try Without Installing" worked fine on my i7-6700K desktop and an old i5 system, but seems I'm not the only one with issues on "Coffee-Lake" systems. New users with Coffee-Lake systems will I suspect, quickly abandon Ubuntu (and probably Linux) after the failure of "Try Without Installing"

Sounds like you are a prison officer who gave an inmate so many chances or a desperate mum who has got a criminal son, ...

1 Like

Rejoice, it was brutal but the battle is won! Follow these ... and yes it works on ubuntu (20.04.1); i just found the archlinux page below to be extremely clear although some minor code differences on ubuntu. If you need more, see the youtube instructional vid also linked.


Side note, initially it wasn't working but after a system restart all was good. Also noticed that if my mouse battery is low and trips out, this too required a restart.

1 Like

Apparently this is more usable

lol, too good. for some i guess.

Hahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahahaha Windows---Stable---perhaps but so slow in any updating. Can't get on with work. I've used Linux in various flavours for at least 25 years now and for those that don't know, it is a reasonably stable system on the majority of equipment that it WAS NOT DESIGNED FOR.
The equipment that Windows runs on was designed for it.
The developers of most Linux distros do an excellent job of TRYING to get Linux working on almost anything.
To say Linux is not stable is wrong. The correct term would be MAY NOT BE STABLE ON EQUIPMENT IT WAS NOT DESIGNED FOR.
That's why a lot of us that have stayed with Linux are happy with Linux. There's a satisfaction in having an operating system run on computers that it was not designed to run on.
It's even more satisfying to know that more than half the worlds' mobile phones have a Linux system that users are happy with.
Spacecraft have Linux running quite happily.
Scientific equipment has Linux running quite happily.
Supercomputers run Linux quite happily.
Windows will only run on equipment designed for it.
If you are having problems, don't blame Linux but do leave feedback on what you have tried in order to avoid having to live with Windows.

1 Like

Hi folks,

Maybe the following solution will help somebody.

Actually, I am OK with scroll speed in Caja, Firefox and LibreOffice.
However I use Chrome a lot and mouse’s scroll speed is definitely not enough there, particularly on large monitors.

The simplest solution for the Chrome is to add Chrome’s Extension: Linux Scroll Speed Fix.
I changed the default setting from 1.9 to 2.1 and it works fine for me.



Since scroll speeds can actually vary depending on the program, and Chrome was mentioned above, I thought I'd quickly share how to increase scrolling speed in Firefox. Especially since I was using it fine for years, then after an update, suddenly the speed was really slow. The fix is easy, and very customisable:

Firefox Scroll-Wheel Speed
In about:config search for mousewheel.min_line_scroll_amount and change the number from the default of 5 - 60 works nicely for me, but might be a bit fast for some, so try 40 or 50.


BEST. SOLUTION. EVER. Thanks man, I've been dealing with this like A LOT. Thanks, there's a special place for you in my heart.


Looks like we're getting closer to the old Windows joke "your mouse has moved, please restart your computer" :slight_smile: