Why the heck is pluma making SOUNDS?!

I booted into a bare-metal 18.04 system today, and while making some notes on a few things it was (very and unpleasantly) clear that about half the time that I hit the down arrow when already at the end of a document, I'd get a clipping / crackling sound from the speakers I have plugged in.

"Alert volume" is muted, so even if pluma was trying to beep - which it had damn well better not be, since that's ridiculous behavor - it shouldn't go through anyway. But it's clearly happening.

What's also interesting about this is that it's inconsistent. The SECOND time I press the key, nothing happens. But if I leave the window alone for a little while (like now, when I'm actually in a VM) and then go back to it, I get the pop / crackle / whatever again. It's like it's powering down the speakers, then powering them up again to (not) play something.

I doubt this ever happened in 16.04, since it's so obnoxious I couldn't possibly have missed it, but I don't generally have the speakers powered up on this machine so I'm not 100% sure on that.

Has anyone else come across this? Is there something ■■■■■■■■ in PulseAudio that keeps screwing around with the sound buffers or power like that?

(Incidentally, pluma in this 16.04 VM doesn't trigger the problem: it's only the 18.04 bare metal one that has it).

Jep, the root cause is PulseAudio being garbage. (Shock! :P)


// Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

(The forum collapses if you use a # even in "code" blocks etc, so i've changed the comment style).
Comment that out and everything works the way it should again.

There are two other bugs here though:

  1. pluma absolutely should not be triggering sounds in the first place
  2. If it's trying to use the "alert" beep, and that's muted, the sound system shouldn't be waking up the hardware either.

#2 is another pulseaudio bug, so that's never getting fixed. And I've just realised that #1 probably isn't on the MATE team and is likely a GTK3 issue, like the context menu font bugs, so I guess that's not happening either.
Oh well. Fortunately, even on a laptop, the extra 0.001A being drawn by an idle sound card doesn't matter to anyone, so the workaround is going to have to be good enough. :slight_smile:

Probably for accessibility - same happens when pressing Backspace in an empty Terminal prompt. [Beep! Reached the start/end!]

Does this still happen even if you disable alert sounds?


:bulb: Try surrounding the text with triple backticks: ```

Yes - that's what I meant by "muted". The "No Sounds" theme itself isn't enough: the alert also needs to be disabled separately, and was.

## TRIPLE backticks eh? Does work though, thanks. :slight_smile:

I think most keyboardists call those graves.

They might, but they'd be wrong to: it's no more an accent than an apostrophe is an acute. :slight_smile:

It's definintely an oddball symbol though: outside of bash, I can't think of a time that I've ever used it at all. I wonder what prompted IBM to add it in the first place. Mind you, it / tilde is the definitive "console" key in games, so the key itself has been immensely valuable to me over the decades, for which I am grateful. :stuck_out_tongue:

1 Like