Wi-fi problems in MATE 20.04

Just upgraded to Ubuntu MATE 20.04. Everything seems to be working fine - though I have not used much of it - but for the wifi connection. Differently from 19.10, it keeps crashing, showing messages of no internet available and asking to try and reconnect. Very, very annoying.
I am now on wired connection of course.

We need more information lostados.

sudo apt install inxi to install a useful utility.

After that, please post the results of either -

inxi -ACDMNSG (which lets you see a lot of things about your install) or

inxi -N (which displays the network stuff)

I can't read this. Either do a screen capture of your terminal or copy the terminal results (highlight the text in the terminal, press control, shift, C to copy it) and paste the results in a reply (Ctrl-V). Format the text with the </> tag.

Edit: Similar to this -
lostados_terminal_screenshot
but larger and readable. It appears that you have an intel wifi link 5100 driver.

2nd Edit: @lostados Please use the following command in a terminal and post the results here - sudo lshw -c network

Sorry, no techie here....

inxi -ACDMNSG

[email protected]:~$ inxi -ACDMNSG
System:
Host: lost-tosh Kernel: 5.4.0-14-generic x86_64 bits: 64
Desktop: MATE 1.24.0 Distro: Ubuntu 20.04 LTS (Focal Fossa)
Machine:
Type: Laptop System: TOSHIBA product: PORTEGE R600 v: PPR61E-00Q00CEN
serial:
Mobo: TOSHIBA model: Portable PC v: Version A0 serial:
BIOS: TOSHIBA v: Version 3.10 date: 01/26/2010
CPU:
Topology: Dual Core model: Intel Core2 Duo U9300 bits: 64 type: MCP
L2 cache: 3072 KiB
Speed: 798 MHz min/max: 800/1201 MHz Core speeds (MHz): 1: 798 2: 798
Graphics:
Device-1: Intel Mobile 4 Series Integrated Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.20.7 driver: modesetting unloaded: fbdev,vesa
resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 19.3.3
Audio:
Device-1: Intel 82801I HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.4.0-14-generic
Network:
Device-1: Intel 82567LM Gigabit Network driver: e1000e
Device-2: Intel WiFi Link 5100 driver: iwlwifi
Drives:
Local Storage: total: 149.05 GiB used: 12.16 GiB (8.2%)
ID-1: /dev/sda vendor: Toshiba model: MK1652GSX size: 149.05 GiB
[email protected]:~$

inxi -N

[email protected]:~$ inxi -N
Network:
Device-1: Intel 82567LM Gigabit Network driver: e1000e
Device-2: Intel WiFi Link 5100 driver: iwlwifi
[email protected]:~$

sudo lshw -c network

[email protected]:~$ sudo lshw -c network
[sudo] password for lost-tosh:
*-network
description: Ethernet interface
product: 82567LM Gigabit Network Connection
vendor: Intel Corporation
physical id: 19
bus info: [email protected]:00:19.0
logical name: enp0s25
version: 03
serial: 00:1c:7e:17:b3:b6
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=1.8-8 latency=0 link=no multicast=yes port=twisted pair
resources: irq:26 memory:ffcc0000-ffcdffff memory:ffcfe000-ffcfefff ioport:cf80(size=32)
*-network
description: Wireless interface
product: WiFi Link 5100
vendor: Intel Corporation
physical id: 0
bus info: [email protected]:01:00.0
logical name: wlp1s0
version: 00
serial: 00:21:6b:4e:1e:7a
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.4.0-14-generic firmware=8.83.5.1 build 33692 ip=192.168.1.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:29 memory:ff900000-ff901fff

Thank you lostados, you provided a most complete picture of your machine. It appears that nothing is out of sorts with your networking set-up though.

I'll keep your situation in mind as I sift through the internet looking for various solutions in the next few days. Unfortunately I have nothing at the moment. Perhaps others with particular experience with your wi-fi chip will post here.

Thanks again.

How did you perform the upgrade?

Have you updated the system since you upgraded?

1 Like
  1. upgraded via Alt-F2 + update manager.
  2. yes, updated more than once a day

WiFi networks seem to have corrected itself and no longer presents any problem. It was however the first time I ran across this problem on upgrading Ubuntu.

Wi-Fi no longer a problem. It must have corrected itself on normal updating of 20.04. It was however the first time I ran across this problem on upgrading Ubuntu MATE.
Altogether pleased with 20.04. It runs beautifully, no (other) flaws identified. My old Toshiba now seems a much more recent laptop!
Thank you very much for your help. I am always very appreciative of this forum.

This problem is related to a regression started on Kernel v5.5.

The fix will land on kernels v5.5.10, v5.4.26, v4.19.111, as in v5.6-rc6.

If your wifi worked again after an update, you probably received one of those kernels above.

1 Like