Wi-Fi Turns Itselfs Down A Few Hours After Open The Computer

My wi-fi adapter turns down a few hours after open the computer. I have to reboot or hibernate my computer to use wi-fi. I'm get this error in just linux distors. I'm using windows XP and Ubuntu MATE with dual boot. But I didn't get this error in Windows XP. How to fix it?

Make sure you are up to date and if that doesn't work, install hwe as detailed elsewhere on the forum as the 4.18 kernel that came with it fixed some internet connection issues for me

Should I update my kernel?

If it's part of the hwe upgrade yes I'm assuming you are on 18.04 if you're on something else make sure your updated, then start looking at drivers and known bugs, as far as manually backporting a new kernel, I've never done that (at least not on Ubuntu) and would be worried about security issues as well as introducing new bugs, but others have and it could be worth a try

1 Like

I'll reinstall Ubuntu MATE and I'll update kernel. Because it can harm my files.
Thank you

You do not need to re-install Ubuntu MATE to update kernels or to install the HWE.

In a terminal simply run this command: sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 and then reboot, that will update you to 18.04.2 LTS

1 Like

This command didn't work. Because my version is 18.04.2 LTS

In that case you are already using the HWE.

The latest kernel version is: 4.18.0-25
You can get this information by running uname -a in the terminal

For your wi-fi. How do you try to restart wi-fi when it stops working in Ubuntu MATE?

1 Like

It's output of uname -a : 4.18.0-25-generic #26~18.04.1-Ubuntu
Wi-fi automaticly turns down nearly 4 hours after startup. If it turns down I have to hibernate or reboot my computer to continue using wi-fi

Let's see if we can do something other than having you reboot to get your wi-fi back. Next time it happens please run this command and lets see if that will get it working again: sudo systemctl restart NetworkManager

Lets find out what wi-fi device you are using: sudo lshw -C network please copy and paste the output of that.

1 Like

Open the terminal and run this: when your wifi dies

sudo systemctl restart network-manager.service

Give it a few minutes to take effect.

Happiness unlocked and back on line

If that didn't work. You can try one of these solutions:

Check if this file has the setting managed to false

cat /etc/NetworkManager/NetworkManager.conf

The output could be:

[main] plugins=ifupdown,keyfile,ofono dns=dnsmasq
[ifupdown] managed=false

Set managed to true

$ sudo vim /etc/NetworkManager/NetworkManager.conf

if you do not have VIM installed you can use your text editor which is Pluma so it would be

sudo pluma /etc/NetworkManager/NetworkManager.conf

Edit:

managed=true
save file

Then run:

sudo service network-manager restart

1 Like

I tried to restart Network Manager. But it didn't solve the problem. Here you are output of sudo lshw -C network

They didn't work. Also my /etc/NetworkManager/NetworkManager.conf doesn't include dns=dnsmasq

It looks like you are using an Intel 3945 Wireless.

From the Welcome screen can you click on Getting Started and go to Drivers

From there click on Install Firmware Package once that is completed let's click on Additional Drivers just to make sure that we aren't missing something.

2 Likes

There was no any additional driver. I tried to install driver of Intel 3945 wireless. Latest version of driver was released in 2007 and not supported now.
I realized, I can use wi-fi after suspending or rebooting. Does poweroff the wi-fi device in suspending?

Similar to here.

I would recommend opening a bug.

Thank you for support.