WiFi - 5 GHz network not working

I loaded Ubuntu Mate 20.04 a few days ago and have not been able to connect to 5G since. I can connect to 2G without any problems. When I try to connect to 5G I enter password but after a few seconds it keeps asking me for the WiFi password again. The connection to 5 GHz worked flawlessly in Windows a few weeks ago but now not in Ubuntu.

My laptop computer is a Dell Latitude E6330 with release 20.04.3 LTS, kernel 5.11.0-41generic x86_64. The laptop has 8GB memory, an Intel i7-3540 M @ 3.00 GHZx4 processor with the Mesa DRI Intel HD Graphics 4000 card.

Not sure how to troubleshoot, can anybody help?

Here is the output of lshw -c network:
*-network
description: Ethernet interface
product: 82579LM Gigabit Network Connection (Lewisville)
vendor: Intel Corporation
physical id: 19
bus info: [email protected]:00:19.0
logical name: eno1
version: 04
serial: f0:1f:af:3f:b1:3e
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.11.0-41-generic firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
resources: irq:26 memory:f7e00000-f7e1ffff memory:f7e39000-f7e39fff ioport:f080(size=32)
*-network
description: Wireless interface
product: Centrino Advanced-N 6205 [Taylor Peak]
vendor: Intel Corporation
physical id: 0
bus info: [email protected]:02:00.0
logical name: wlp2s0
version: 34
serial: a4:4e:31:3d:91:94
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.11.0-41-generic firmware=18.168.6.1 6000g2a-6.ucode ip=192.168.1.10 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:31 memory:f7d00000-f7d01fff

I have the same wifi card, I had to add an option in /etc/modprobe.d/iwlwifi.conf

options iwlwifi 11n_disable=8

Reboot and test ...

Thanks pavlos_kairis - just rebooted and still no connection to 5G. After 20 seconds it just keeps asking for the password . . .

Here's the output of iwlwifi.conf, is this correct?
# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system. When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod)
&& /sbin/modprobe -r mac80211
options iwlwifi 11n_disable=8

Just curious - I am not sure I have the expertise on this issue. What month/year was the laptop made?

I ask because if the laptop and specifically in this case the WiFi card was made after April 2020 or thereabouts, the kernel in UM 20.04 LTS might not be new enough for the WiFi card. Therefore, it is possible you need a newer kernel that has the information on the newer WiFi card to work with the software.

I am not sure how to update the kernel on an LTS release. If this is the issue (I don't know) then maybe using a newer release like UM 21.10 to see if it will work or maybe use a rolling release distribution like Manjaro or Endeavor that has a newer kernel. Alternatively too you can go into the testing branches of UM which I think would have the newest kernel.

I am no expert with this dilemma that affects newer hardware on an LTS. All this is FYI to see if it can help you. It may be the hardware is older than the LTS and all this is moot.

Best of luck! :slightly_smiling_face:

that's correct. My output from iwconfig:

wlp3s0    IEEE 802.11  ESSID:"xxxxxxxx"  
          Mode:Managed  Frequency:5.22 GHz  Access Point: xxxxxxxxxxxx   
          Bit Rate=81 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=60/70  Signal level=-50 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:39   Missed beacon:0

Here's a script available on the Net, download and run.

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info

The wireless-info.txt file generated is about 39K. Paste at pastebin.com and post the URL.