WiFi card not working, and computer shut down problem

I have recently installed Ubuntu Mate (UM) 18.04.2 LTS on my Dell Inspiron 1501 laptop computer completely removing Windows Vista. I have downloaded and installed the UM updates. I am currently having two problems with this installation:

  1. The computer’s built in wireless card is a Broadcom Ltd. BCM 4311 802.11a/b/g (wireless 1490 dual band WLAN mini-card) [14e4:4312] (rev 01). It no longer works after I installed UM. I had no problem with it when using Windows Vista. I have plugged in a USB WiFi adapter and it is connecting to my router but I would prefer to get my wireless card working.
  2. When I attempt to shut down my computer a blank screen appears with the UM icon in the centre and the flashing “progress” dots below it. The dots progress left-right for 3 dots and then stop and nothing else happens, it is stalled at this point and stays there. To shut down the computer I have to press and hold its power button.

Any help with these problems would be very much appreciated. Since I am a casual computer user, not a geek, I would appreciate any replies to be in plain English and avoid technobabble as much as possible. I am somewhat familiar with using commands in Terminal.


In regards to fixing your broadcom wireless card, please open a terminal and enter sudo apt install firmware-b43-installer, wait for the install and then reboot. Your wireless card should then be working.

See - Broadcom wireless tip for an expanded version of this advice.


Thanks for your reply. I shall give it a try tomorrow, I'm computered out for today.




Thanks again for your reply/suggestion to my inquiry.

I am a little embarrassed to inform you that, as so many times, my problem appears to have been between the seat of my chair and the keyboard. When I installed Ubuntu Mate on my Dell Inspiron laptop it apparently shut off its Broadcom WiFi card so the computer would not connect to my router. I plugged in a USB WiFi adaptor and was able to connect to the router that way, but still not via the machines WiFi card. After trying many things, mainly drivers, to activate the card, all failing, I twigged to the fact that the laptop’s keyboard has a Function/Key combination to turn the onboard WiFi card on/off. I performed this key combination, the card turned on, and the laptop has connected to the router with no problem ever since. No USB WiFi adaptor required. Live and learn.

This laptop is running UM OK except that it will not shut down properly. When I attempt to shut it off the UM logo appears centre screen with the progress dots below it, but it only progresses three or four dots and stalls. I have to press and hold down the computers power button to shut it off. Not a big problem, just not right.


Albert Smith..........

Try shutting down with a terminal command - sudo poweroff Please let us know if that works.


I tried your suggestion, sudo poweroff, to shut down my Ubuntu Mate OS Dell laptop, but it worked the same as shutting down by clicking the shutdown icon on the desktop. Using the terminal command the Ubuntu Mate icon appears with 5 progress dots below it on a blank black background, the shutdown progress proceeds for 3 dots and stops and stays there no matter how long I wait. I have to shut down the machine by pressing and holding the power button until it goes off, just a few seconds. I have 3 computers running UM and this is the only one that does not shut down properly. Another mystery in the world of computers.

Regards, and thanks for your patience.............


Could you post the results of inxi -ACDMNSG entered in a terminal? A screenshot should be sufficient if you don't want to copy the terminal text. Thanks Albert.


As per your instruction, I have run the terminal command “inxi – ACDMNSG”, and taken a screenshot of the result. It is inserted below.

Thank you for your continuing help with this laptop shutdown problem. It is interesting that this machine sits between a desktop and a netbook both running Ubuntu Mate and they both shutdown no problem. The desktop and netbook both have Intel processors, the problem laptop has an AMD processor.


Albert Smith............

Please post another screenshot of sudo inxi -m which should show a bunch of information about memory. I once had a machine very much like this old AMD Turion Dell. Thanks Albert.


I must say – you do stay right on the job. Its certainly interesting and I am learning a lot. Here is the screenshot of running the Terminal command “sudo inxi –m”


Albert Smith...........

Everything looks good as far as I can tell Albert.

Please post a screenshot of Software & Updates -> Additional Drivers. You are probably using the Broadcom STA wireless driver from bcmwl-kernel-source rather than having installed the firmware-b43-installer.

Your problem may be BIOS related - See


the last entry where someone with a Dell Inspiron 1501 found a solution for shutting down successfully. I quote sugeek85 -

"What my problem ended up being was a setting in the bios. On my machine it's called "PowerNow" under the "Advanced" tab in the bios. It was set to "enabled", and when I disabled it, shutdown and reboot immediately worked again."

It's worth a look at.

Another thing to try would be to use System-> Log Out albert, and from the next screen, attempt to shutdown or reboot.

Just a suggestion...


I am a very happy man – with many thanks to you and sugeek85. I accessed the BIOS on my Dell Inspiron 1501 laptop and disabled the PowerNow setting, under the Advanced tab and now the machine shuts down perfectly. I tried starting and shutting down a couple of times and it worked properly each time.

Best regards.

Albert Smith............


I have sent you a separate message regarding the PowerNow BIOS setting. It worked (happy).

Per your request, I am attaching herewith a screenshot of the Software & Updates –> Additional Drivers display. I really don’t know what it is telling me. I do know that the WiFi card is working.


Albert Smith.

Great to know that shutdown now works. From what I see on the Additional Drivers screenshot, you DO have the firmware-b43-installer up and running. My additional drivers displays the same thing. Please select the answer that worked and mark it as the solution.