WiFi Disabled, Cannot Re-Enable

A couple of weeks ago I did a nuke-n-pave of my reliable old T420 Thinkpad, which had been running Manjaro. I'd run Manjaro for a year or more, and kind of missed UbuntuMATE, so took advantage of the 22.04 to come back to the fold. Everything ran great, just like it used to, until I started up the other day and had no internet. All I've got is a network icon (not the WiFi fan) with a little 'x' on it. The drop-down box says Enable Neworking is enabled, Enable Wi-Fi is not - and even if I try to enable it, nothing happens. When I look in Edit Connections the WiFi part is fundamentally all blank, although it does remember that it was hooked up to my home network some days ago.
I tried turning off the firewall, numerous restarts, and finally plugged in a little Panda Wireless WiFi dongle as a last resort, but nothing changes.
Any ideas? Thanks for thinking about it!

I like Manjaro’s Mate and Solus too. Manjaro to me is better and their Cinnamon & GNOME versions are fantastic. I am using Pop!_OS for now so not sure what’s going on with UM. Was thinking of installing it on a separate SSD but will wait with due to all these small bugs.

Yes - might have happened after an update, have been updating almost every time I've used it. Should have waited maybe another couple of weeks before installing, just couldn't restrain myself! Thanks!

Two things I can think if right off. First is check the bios and make sure nothing has changed.
Second is if you have an old kernel that worked boot into that kernel and see if it works.
I know realtek is having trouble with the new kernels and I had that happen twice on my old laptop with a Broadcom wireless card.
I have a Dell laptop where the bios changed for some unknown reason and disable WIFI.
If neither of those work run from a live USB installation and see if your WIFI card is still working.

Did you update? Maybe boot up the live session and play with it for a while; that can often be a problem with an update to the 5.15 kernel.

jymm, Good suggestions! BIOS seems to have no reference to the WiFi, and everything else looked fine. I tried a USB WiFi dongle - Panda - that worked on another computer I had WiFi trouble with, but no dice. The computer does work fine on Ethernet.
Booted from the original MATE USB drive I'd made, same behavior - as if the WiFi didn't even exist. Downloaded the latest MATE 22.04 and booted to it, same result. Updated the existing MATE installation, still no change.
I'm wondering whether it is a hardware failure? But if so, why didn't the WiFi dongle work...
Thanks for your patience, have had a lot to do and just put this aside for a few says. Appreciate it!

Basil_Cat - yes, have been updating almost every session, as I hadn't waited long after 22.04 came out to install it.
Today I got back to trying to figure the problem out, and found that everything runs fine on Ethernet, so I downloaded the current 22.04 file and booted from that. But it made no difference, everything seems the same.
Will try to find something running off an older kernel to try - although this installation did run fine for a couple of weeks before suddenly dropping WiFi.
Tried running it off a WiFi dongle, but no luck there, either... which would seem to knock out the idea of a WiFi hardware failure.
Thanks for thinking about it - will post if I figure it out!

Try burning a different OS like PC Linux or Solus to a USB, something not based on Debian/Ubuntu and see if the wireless works for that. Has that dongle ever been used with Linux? Dongles are notorious for not supporting Linux.

First run this command then copy and past it here: sudo lshw

That will print out your hardware, scroll down until you find *-network
it should look like this, here is my wifi card:
*-network
description: Wireless interface
product: Wireless-AC 9462
vendor: Intel Corporation
physical id: 14.3
bus info: pci@0000:00:14.3
logical name: wlp0s20f3
version: 00
serial: 58:96:1d:2c:15:4b
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.16.19-76051619-generic firmware=67.8f59b80b.0 QuZ-a0-hr-b0-67.u ip=192.168.1.15 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:16 memory:d3510000-d3513fff

If that is missing, I am guessing you wifi card has failed, if it is there maybe the correct driver can be found. If another OS works it could be a kernel problem. I had that problem when I wanted to try PC Linux and a qualcomm card. My wifi wasn't supported and I was never able to find the correct driver to make it work.

Here is a list of commands cheat sheet for those of you who can't remember them and/or are terrible typist:

It is a very extensive list worth bookmarking or copying.

Brilliant! Yes, it is missing. This Thinkpad is almost 10 years old, I guess the card has failed - since it worked very well when UbuntuMATE 22.04 was first installed, and has worked with everything I've ever run on it. Will research replacing it.

Thanks for the cheat sheet - and the great tip!

Reid

TBH that sounds pretty unlikely to me. Not impossible, certainly, but very unlikely.

Since it's a laptop, you almost certainly have either a physical cutoff switch for the wifi, or a Fn-something key combination for it, and both are extremely easy to trigger by accident without ever knowing - I'd say very nearly 100% of the "my wifi stopped working!" complaints I've seen are caused by that, with about 1% from kernel breakages and actual hardware failures combined.

1 Like

@arQon @re1d I also have a T420 and it, indeed, has a tiny physical RF switch, on the right side just next to the optical drive.
And yes, I've once managed to switch it off involuntarily. Took me some time to discover that.
It is running Ubuntu-MATE 22.04 at the moment.

1 Like

I'm fairly confident that my Dad's Thinkpad is also a T420, and he had exactly this problem about 2 months ago, which is why it's still fresh in my head.
(Then he had it with the neighbour's Dell, except there it was a Fn-blah combo that got him - he spent about 30min going ever every mm of the case looking for the killswitch before giving up and calling me. :P)

arQon, tkn, et al -

That is absolutely brilliant, and spot-on for the problem. I'm sorry to be so late in answering - I'd tried replacing the wifi module without result, and given it up as a bad job. So didn't check the topic after that. But your advice RE: the switch worked. I am very grateful!

Hope you both have a wonderful Christmas - you've given me a great gift! -Reid

3 Likes