WiFi disconnects over time, until reboot is performed - 18.04.4 LTS - Qualcomm Atheros AR9285

Hi Everyone

I'm trying to solve, with almost no success, the above issue. More in details, after some time of properly working wireless networking, it suddenly disconnects and no network is available anymore. I then reboot my laptop and everything works again, until the same issue occurs.
Now, I tried several solutions (action :arrow_right: result):

  • searching for additional drivers through software & updates :arrow_right: no additional driver available
  • mounted Ubuntu MATE .iso as cdrom and checked the "CD-ROM with Ubuntu" box, then searched for additional drivers :arrow_right: no additional drivers available
  • sudo lspci :arrow_right: both Network and Ethernet controllers are shown:
[...]
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
85:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8072 PCI-E Gigabit Ethernet Controller (rev 10)
  • lshw -C network :arrow_right: again, they're both shown (not the whole output is reported below):
*-network                 
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       logical name: wls1
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=5.3.0-53-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
  *-network
       description: Ethernet interface
       product: 88E8072 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       logical name: ens5
       capabilities: bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: enp0s29f7u6
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=*** link=yes multicast=yes
  • sudo ifconfig wls1 down && sudo ifconfig wls1 up :arrow_right: nothing changed

I don't know what else to try, any help would be much appreciated.
Thanks in advance

Hi !

Are you using a Bluetooth device at the same time ? Is your network card also doing Bluetooth ?

Hi Olek,

My card has no bluetooth functionality (pretty old hardware), though few years ago I managed to insert a little BT card in the laptop but it never worked either under Windows either under various Linux distros. So it's like if I never mounted it.
For this reason I would assume it is not related to this issue, even because I had the chance to try different distros on the same setup and, as far as I remember, they didn't suffer from this problem.

Last minute update: I left the laptop suspended for a couple of hours and now that I've logged back in I can find my wireless working again. Maybe this info could help with troubleshooting. Now, I am just assuming, but can be something related to the OS power management?
Anyway, I expect it to stop working again within some time..

Bill, modinfo ath9k will show at the end parameters that could be used, for example to disable encryption you could add to /etc/modprobe.d/ath9k.conf the line, options ath9k hwcrypt=1 Can you try some parameters and see if the wifi behaves ...

1 Like

When it is getting disconnected, can you do a dmesg and share some error messages ?

When connected, d/l the wireless-info script which helps diagnose issues

wget https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info
chmod u+x ./wireless-info
./wireless-info
cat wireless-info.txt | nc termbin.com 9999

provide the link so we can take a look.

1 Like