Wifi not working on 20.04.3 Mate

I just installed Ubuntu Mate on my laptop (Acer Aspire 5) and I don't have any option for wifi. I can only connect through cable. When I installed it I didn't get any option to connect to the internet to download additional drivers. Help, please. Do I need drivers (but I checked it and there are no additional drivers available, says the OS)? Is my copy of Mate corrupted?

You need to tell us more about your system. What is the name and make of the WIFI card?
You can use this command to find hardware information:
sudo lshw
on install "hardinfo" which will be found under Applications> System Tools> System Profiler and benchmark.

Also check your bios. On my Dell Inspirons WIFI has to be enabled in the bios to work.

Yeah indeed on my Dell Inspiron laptop, I can tick on the Wireless Network to enable it on the BIOS menu. However, yesterday I encountered another problem all of a sudden when I was connected wireless and suddenly I lost the connection. After working things out like opening terminal window to run rfkill unblock all commmand OR re-installing libraries, the issue was not resolved!

I found by accident the solution to this problem by searching more on the askubuntu forum for other alternatives. On DELL LAPTOPS, there is a key combination Fn+F2 to ENABLE the
wireless utility again. And this worked out fine and now back again wireless.

I think he needs to check the configuration for his Acer laptop and check the network adapter on the connections setting. For the 'hardinfo' utility, he can open 'Menu - Administration - Synaptics System Manager' and then search AND install 'hardinfo'. This will be installed after ticking on this and he may finally view it from 'Menu - System Tools - System Profiler and Benchmark'. ALL Available hardware devices are listed there!

I checked and I don't have Network Controller under PCI Devices. Which is weird, since the wifi worked when I first opened it (it was still on Windows). I looked at the terminal and I have this:

*-network UNCLAIMED
description: Network controller
product: MEDIATEK Corp.
vendor: MEDIATEK Corp.
physical id: 0
bus info: pci@0000:02:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm cap_list
configuration: latency=0
resources: iomemory:600-5ff iomemory:600-5ff iomemory:600-5ff memory:6003000000-60030fffff memory:6003100000-6003103fff memory:6003104000-6003104fff

Is this it?

I checked my BIOS and the only thing I can find there is Network boot, which is disabled. Is that what I'm looking for?

Here’s a photo of my BIOS:


Also, the built-in webcam doesn’t work well with the tech in my company so I’d like to use an external webcam (A4Tech PK910H) instead. The problem is that my laptop doesn’t read this plug-and-play webcam. How do I get this to work? How do I disable the built-in webcam and enable the external one?

I would suggest you post your picture here, not on Google drive to get more help. Not everyone has a Google Drive account. I don't, and never will.

Screenshot at 2021-12-27 06-11-54

Better to use the drive symbol with the up arrow to upload your picture.

The photo's too big to be uploaded here, so I hope you don't mind Imgur: Imgur: The magic of the Internet

I don't know what to tell you, but maybe the picture can get you help.

Sorry, just wanted to make sure before I tinker with things I don't know how to fix. I don't know my way much around the BIOS, you see.

Well, I enabled it, but I still don't have wifi.

These might help you. It seems your device may only be supported by a newer kernel.

Ubuntu 20.04 does not have MediaTek driver MT7921 for WIFI & Bluetooth?


Thanks, I’ll check it out.