Will drivers be a problem?

I’m thinking about installing Linux on my Lenovo Thinkpad Edge E540 laptop. I checked on Lenovo’s drivers page for it, and I don’t see any Linux drivers there. I’m pretty sure it has one of those specialized GPUs where a default driver won’t quite work. Do drivers exist for this somewhere, and will it be a problem if I install Linux?

Edit: I see it’s certified by Canonical for Linux… Ubuntu 12.04. Does that mean that all versions of Linux will be able to pick up the drivers? Or does that just mean that Linux can be preinstalled by OEMs if they have the drivers (I noticed there weren’t links to download them there either)?


Linux support on Lenovo laptops is very good.
I have a similar laptop, Edge e520 and never had any issues. Everything just worked out of the box: video card, ethernet adapter, wireless adapter, bluetooth, etc.

At work I had an x230, no problems whatsoever. I also had another Lenovo prior to the x230 where everything worked too, but can’t remember the model.
I also have an x1 carbon gen2 (using Arch there), again no issues there.

If for some reason, you do encounter issues, there are usually easy to solve.
I’d definitely give it a try.

Thanks. Do the trackpoint, multitouch touchpad gestures, and fingerprint scanner work? I use them all a lot on my Windows machine, and they all seem like unique features that might not be fully supported.

Trackpoint works for sure. About multitouch gestures, not sure as I only use two finger scroll (which works properly). I’ll check other gestures and update you.
About fingerprint scanner, never used it so can’t tell if it works. I’ll try it out and let you know

I just tried booting from a live disc, and I couldn’t use the trackpoint properly. The Right- and middle-click buttons don’t work. Neither does two finger scroll or two finger right-click. It makes it impossible to use without a mouse. I’m not sure how I’d test the fingerprint scanner in a live environment since there’s no password needed. Speaking of which, when I upgraded Windows on another computer with a fingerprint scanner, I was unable to use the fingerprint scanner since the scanner itself stored my fingerprint. It seems like that same issue would apply on Linux–even with a dual-boot.

I tried using the fingerprint scanner and it didn’t work. Might be possible to use it with some tinkering but I didn’t try as I don’t really use it.

Weird that touchpad is not working properly, they worked for me out-of-the-.box with 4 different Lenovo laptops. Did you check the settings? Maybe there is unchecked box that prevents gestures (can’t check the settings myself as my computer with Mate is at home)

For the trackpoint buttons, I recall now having problems with it as well with my x230 using both Ubuntu 14.04 and Fedora, so that might need tinkering with to make it work. Have you seen this post?