Window size issue after do-relase-upgrade to 18..04

I just completed do-release-upgrade on a Dell Latitude 2100 mini laptop to 18.04 from 16.04. (It only took two tries - I did make a Clonezilla backup first.) I had updated from to 16.04 from 14.04 a couple of years ago by the same method. That was the first time I had ever done a release update. The computer boots and seems to work except…

The computer serves as a music player in my workshop. I have a low privilege user account which automatically logs on and opens audacious on the left half of the screen and resumes playing any .mp3 files in the play list. caja opens on the right half of the screen and displays my music library. That is what it did in 16.04 and 14.04. That is what it almost does in 18.04.

The first time I booted after the upgrade all worked as expected. The account performed its autologon, audacious and caja opened. Each occupied half of the screen. I selected a directory of music files in caja and dragged them to audacious. So far, so good. I clicked on the button in audacious to start playing. That worked. However, the audacious window increased in width to occupy about 60% of the screen. I can NOT reduce the width of the window. I can decrease the height of the window.

Further investigation finds that some windows can be set to any size (terminal, caja, firefox) but audacious seems to have a minimum width. system monitor seems to have both a minimum width and a minimum height.

The display resolution is set to 1024 x 600 - which is correct for this device. I have seen limitations on window size for dialog windows but never for application windows. I am at a loss. Any suggestions?



On 18.10, I can stretch Audacious’ window down to 441 px (it might slightly vary with the theme used), so unless the version included in 18.04 has a bug, you should be able to resize it to 512 px, 50 % of your desktop’s width. Audacious’ version seems to be the same between 18.04 and 18.10, so I doubt it would behave differently.

However, I’ve seen similar issues with some apps windows getting wider with no possibility to resize them when file names or directory paths were too long. It happened to me with Transmission and Caja.

So, does it happen on Audacious with any music file, or only when the path to it is very long or the filename is? or maybe the titles of the songs/albums (as Audacious displays them from their metadata)?

Thanks terzag,

I was at a loss in how to resolve this but not for more things to test…

The path length was a good suggestion. However, the issue occurs even before I add any audio files to audacity. Here is what I have been able to find:

Note: the upgraded installation was 32 bit

Ubuntu Mate 18.04 64 bit - I can squeeze audacity horizontally until I hit the right end of the icon or button bar and vertically until it almost becomes unusable.

Ubuntu Mate 16.04 on a Raspberry Pi 3B+ - same results

Ubuntu Mate 18.04 on a Raspberry Pi 3B+ - same results

Ubuntu Mate 18.04.1 32 bit run from the live image on a flash drive on the Latitude 2100 - same results

This tells me that the issue IS related to the do-release-upgrade process. I guess I now need to decide if I want to re-install 18.04 from scratch or live with the issue. It is not a show stopper.


p.s. As to system monitor… I have tested that on the other systems as listed above and on my CentOS 7.5 Mate desktop. In ALL cases I am limited in how small I can make the window. I never noticed this before as I generally make the window BIGGER so as to be able to see more detail in the graphs etc.

You mean Audacious? Or is the issue with Audacity?

This tells me that the issue IS related to the do-release-upgrade process.

Do you use the same theme (Gtk + icons) on your installation as on the versions that don’t have the same issue (Pi, LiveCD…)?

Also, on your installation that has the issue, does Audacious (if that’s indeed Audacious and not Audacity) use the GTK interface? At some point a long ago, the devs switched to Gtk3, then went back to Gtk2, then had a Qt version… Current versions use Gtk (3, I guess) but I’m not sure about the one that was on 16.04 and maybe you’ve kept old packages.

Have you tried to create a new user account to check if the issue appears too? It’s possible that the issue is related to some config files (or gconf/dconf settings) so a new user with base settings would tell if the issue is related to your personal config files or is general.

In ALL cases I am limited in how small I can make the window.

Well, there’s a limit to the resizing of windows in all apps but in any case, you should be able to make the windows of Audacious smaller than 512 px.

The issue is with Audacious. I always get the two confused. In fact, when I was testing, I accidentally installed Audacity first. Except for this particular machine I always use VLC for my audio/video needs. I just wanted something simpler and that is why I chose Audacious.

And now for page 2 (as Paul Harvey used to say)

Back to my troubled machine… I deleted all tracks from the play list. I could then resize the audacity window just as in the other installations. (I had not actually added tracks to the other test instances.)

Starting over I closed and re-launched audacious. I sized the window to half screen. I then copied some tracks (files) from caja to the playlist area of audacious. So far, so good. I then started playing the tracks. The audacious window expanded.

I observed that the “Info Bar” - the black area at the bottom of the window - expanded to accommodate the album cover image + track title + the graphic equalizer like animated icon. This forced the window to get wider.

It appears that when a group of tracks are loaded and playing starts, the Info Bar expands as necessary for the LONGEST track title. The window is thus stuck at that size until the playlist is deleted.

I think the Info Bar did NOT expand when using 16.04 but I might have been wrong. I never looked very closely. I have been using the ersatz jukebox for several years. I throw some tracks on the player, play them, delete them and load some more. I never really paid attention as long as the music issued forth.


It’s possible that on 16.04 they used a different toolkit and the info bar behaved differently. Or you just never played a track long enough for the stretch to happen. If you want to be sure, you can check this easily with a 16.04 LiveCD.

Anyway, you can disable the info bar from the menus (shift + ctrl + i). Have you tried to do it to confirm that the issue doesn’t happen when the bar is hidden?

Good morning terzag,

I did try hiding the info bar. It made no difference. I have had the same 400+ albums from my CD collection, burned to .mp3, on the machine since I started using it as a jukebox. I am sure I played albums with loooooong track titles in 16.04.

That is a good idea about testing with the 16.04 LiveCD. I had considered restoring my 16.04 Clonezilla image to the computer. But it is a nice day weather wise (after several days of cold rain) so probably not - at least until I get a rainy day again.

Thanks again for all of your assistance,


Not being one to let sleeping dogs lie… I decided to try this experiment on one of my Raspberry Pi machines for which I had 16.04 and 18.04 images handy. I connected a “real estate challenged” 1024 x 768 monitor. I sized audacious to the left half of the monitor and caja to the right half. I dragged across a selection of .mp3 files. When I started audacious playing on 16.04 its window stayed the same size. On 18.04, same test scenario, the audacious window expanded.

So I guess that is the way it will work.


p.s. Real estate challenged 1024 x 768… I remember my first color CRT monitor - an NEC Multisync 14 inch. I think it was only 768 x 640. And it cost a little over $1000 US. Amazing how things have changed. And the Raspberry Pi3B+ is probably more powerful than the i386-20 which I had under the Multizync. Of course the 386 was not plagued with Meltdown, Spectra and all those other hardware vulnerabilities. Progress!