Wine install doesn't work


#1

Dear Ladies and Gentlemen,

I am trying to install Wine on Ubuntu Mate 16.04 but it won’t work. I can’t install it from the software center because it can’t find it. Afterwards I used this manual:

https://wiki.winehq.org/Ubuntu

But when I add the repository my terminal says ‘You have held broken packages’. I also looked up the internet but no solution could help me. Maybe somebody knows if there are any differences between the installation in Ubuntu or Ubuntu Mate, or maybe I need Ubuntu Mate 18.04… I run it on a Raspberry Pi.

I hope that somebody can help me.

Best Regards


#2

I have not tried it but maybe this link may be of help


#3

I hope that works, but I spent a lot of time trying to do things like that with the Exagear software and now consider it a waste of both time and money.


#4

@osman

You can install wine:armhf on Ubuntu MATE for Pi, but if you install that directly on the host note it’ll only be useful for running Windows ARM binaries. Running Windows x86 software via Wine on a Pi requires wine:i386 + QEMU or Eltech’s Exagear software. Recently several lively threads have sprung up regarding this on the Raspberry Pi forums if you’d like to read more.

That said, if you want to continue installing wine:armhf please post your exact error message here which specifies the reported “broken packages” and then we can troubleshoot. Sometimes it comes down to running sudo apt update, explicitly installing the “not going to be installed” dependencies, sudo apt install --reinstall on the conflicting package, or removing one.