Wine Installing wine32:i386

I successfully used WINE to run ACAD2000 (32bit) and Irfanview (64bit) for many many years. My SYNAPTIC PKG MGR installations of it were successful in '21, '22, and '23. I am now trying to install WINE into MATE 2024.04. I much prefer using synaptic or .deb over PPA installation.
I have installed i386 and verified it is present with dpkg –print-foreign-architectures. I installed wine-stable and wine via synaptic. All should be good. At this point, I did not have problems previously

Some diagnostics:
mark@mark:~$ wine
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32:i386"
Usage: wine PROGRAM [ARGUMENTS...] Run the specified program
wine --help Display this help and exit
wine --version Output version information and exit
mark@mark:~$ wine --version
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32:i386"
wine-9.0 (Ubuntu 9.0~repack-4build3)

Entry that supposedly will do the trick – but doesn’t
mark@mark:~$ sudo apt-get install wine32:i386
[sudo] password for mark:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package wine32:i386

What am I doing wrong or what do I need to do to get wine32:i386 installed?

If the OS is 64bit, why do you want to install wine32? Wine can emulate both, 32- and 64-bit windows. You need to set WINEARCH=win32 ... did you install libwine:i386 ? This may help

Autocad does not seem to work well with wine, consider FreeCAD, a great Linux app.

1 Like


libwine:i386 and wine32:i386 are installed and WINEARCH and WINEPREFIX are established. All seems good based on following:

mark@mark:~$ wine --version
wine-9.0 (Ubuntu 9.0~repack-4build3)

I uninstalled wine and wine-stable in synaptic. When reinstalling got a broken package message, but then installed wine and then wine-stable and all seemed o.k. The following diagnostic seems to indicate all is o.k.:

mark@mark:~$ wine --version
wine-9.0 (Ubuntu 9.0~repack-4build3)

But when I try and install the Irfanview app I get the below error message, and when I try and run ACAD2000 (after installed), it does not open up.

mark@mark:~$ wine /home/mark/UTILITY/Apps_WINE/Irfanview/i_view64.exe
wine: could not load kernel32.dll, status c0000135

Something seems to be a bit scrambled behind the scenes. Might there be an easy way to solve the kernel32.dll problem.

Load wine as an appimage. The very early irfan view that runs on win3.11 also runs on wow64.

It is a misconfiguration, remove .wine/ and try again, see kernel - Wine: could not load kernel32.dll, status c0000135 Kali Linux - Unix & Linux Stack Exchange

I d/l iview467_setup.exe, right click, install with wine (my version is wine-9.0), it did, and works.

I did reinstall wine and wine-stable and did not meet with full success as I described.

Interestingly, I did a system search for kernel32.dll in both my MATE 2020.04 and 2024.04. kernel32.dll resides at 3 locations in both, and particularly in /home/mark/win32/drive_c/windows/system32. So it is present, just not detected.

o.k., though I am not totally skilled at it, I will remove wine and wine-stable again from synaptic and do a purge wine, then rebuild and report back.

remove /home/mark/.wine

o.k. here is where I am at. My ACAD2000 (32bit) is installed and working. I forgot that I have to move some .dll files within the program for it to work.

Below is what I get when I try and install Irfanview (64bit). So just checking, does it still look like removing ".wine" might be the solution to wine looking for kernel32.dll when installing a 64bit app?

mark@mark:~$ wine /home/mark/UTILITY/Apps_WINE/Irfanview/i_view64.exe
wine: could not load kernel32.dll, status c0000135

Don't remove .wine, you will lose acad.

Maybe the path should be shorter like /home/mark/ Downloads/iview467_setup.exe

wine Downloads/iview467_setup.exe

Why are you loading the 64bit version, this whole thread is for 32bit, just get iview467 (3.4MB).

I right clicked in the ~/Downloads/iview467_setup.exe and it installed.

1 Like

My title probably was not the best, I wanted help with WINE to install it for both 32bit (ACAD) and 64bit (Irfanview) use. I am trying to load the 64bit version of Irfanview given more capabilities.

I believe I tried equivalent to what you suggest: I put iview467_setup.exe on the Desktop - very limited path. Right clicking it opens a pop-up requesting what application do I want to open it in. WINE is not given as an option?

I started with a new VM, ubuntu mate 24.04 I followed Method 1 of the link I provided.

sudo apt update && sudo apt upgrade
sudo apt install wine64
sudo dpkg --add-architecture i386
sudo apt update
sudo apt install win32 (it will bring many files)
wine --version tells me wine-9.0 (Ubuntu 9.0~repack-4build3)

rm -rf .wine
winecfg (start fresh, it will pop a window, Wine Configuration)
wine iview467_setup.exe (install successful)

why the File Manager does not offer wine as an installer?

It is missing a link, the following line with do it.

sudo ln -s /usr/share/doc/wine/examples/wine.desktop /usr/share/applications

Now, open your File Manager, right click on iview, open with ..., at the end of the list is wine

Hope this helps.


I will tentatively copy your instructions which sound like a complete uninstall and start over, eg, I will lose my working autocade. But before so doing, is it possible that you might know how to handle the following which I discovered by googling:

Using "sudo" infront of the install attempt for WINE opens a fully functional WINE in a terminal. Then of course, when the terminal is closed, Irfanview is gone. Seems like changing file permissions of ??????? would get me up and running.

Of note, thanks for hanging in with me in combating my WINE install problems.
mark@mark:~$ sudo wine /home/mark/UTILITY/Apps_WINE/Irfanview/i_view64.exe
[sudo] password for mark:

You should not use sudo in front of wine. Wine keeps everything under your home dir in the ~/.wine dir. Wine is an isolated env that needs write perms under your home dir (which it has).

There are lots of pages to read about wine, how it works, the internals, etc. Personally, I'm not using wine, I use plain linux. But I can run tests on VM's to help out on this community forum.



I have both ACAD2000 and Irfanview!!!!!!!!! I owe you a big apology, but I will return and edit this post with an explanation and what worked, actually an early suggestion on your part.


1 - I overlooked where you provided a link to effects of reinstalling ".wine"
2 - I have copied your method for WINE installation for possible future use.
3 - The "sudo" install method in the terminal was interesting in that Irfanview was functional in that mode only, but I understand that at the least it was not "good etiquette" and was not a permanent solution.
4 - What got rid of the "Wine: could not load kernel32.dll" message and made WINE functional was indeed, remove ".wine" and run an app install again which updated the ".wine". I did this with safety by renaming ".wine" and then the app install. I now would think of ".wine" as sort of a configuration file.
5 - My ACAD draws just fine but balks regarding plotting device. I did an ACAD removal from the win32sub-folders, but somewhere ACAD presence is still recognized so a reinstall is not a start from scratch clean reinstall - never had this problem in all the years I have used ACAD2000 under WINE. I am guessing I need to remove the win32 folder, then reinstall ACAD.
6 - For someone who does not use WINE, your ideas and assistance got me to end goal which is important to my PC use satisfaction. So I really owe you a big thanks for your suggestions and the time you spent helping even though out of your normal working domain.
7 - I am now a "happy camper", hoping I do not screw things up trying to get ACAD to be fully functional - I got homework ahead which is all in my camp.