Working Visual Bell working on cosmic

Currently on 18.10, cosmic cuddlefish.

I strongly prefer a visual bell, but like to have the bell turned on to flash the screen to get my attention. I used dconf-editor to edit:

/org/mate/marco/general audible bell (set to false)
/org/mate/marco/general visual-bell (set to true)
/org/mate/marco/general visual-bell-type (left to fullscreen)

In the mate-terminal, I left the choice "bell" selected for the default profile. When I try to tab complete something in the terminal with multiple choices, I expect the screen to flash while the possible choices are displayed (this is how it used to work). Instead, I just get an annoying default alert sound.

For now I have disabled the terminal beep, but find this less than ideal. Any solutions?