Wrong monitor size detected after software update

video
drivers
Samsung

#1

I installed Mate 16.04 on my new desktop and everything worked great. Today I did a security software update and, after rebooting, my 24" Samsung monitor is detected as a 7" Samsung monitor!

Googling for a solution hasn’t proven very helpful. Can anyone suggest a solution or point me in the right direction, please?


#2

Possibly @v3xx’s post might help Undo Most-Recent apt-get install


#3

Thanks for the suggestion, but it appears to be a driver issue.

Between my last reboot and the software update, I had also changed the graphics driver from X.Org’s Nouveau to Nvidia’s 36n.whatever. After changing it back to Nouveau and rebooting, things look better.

However, the monitor detection is still wrong - 7" instead of 24".

I can live with this, but why is this a problem at all? I have Ubuntu Mate 16.04 installed on an older 32-bit machine with a Samsung 27" monitor and it detects everything correctly. Why the problem with the 24" monitor? Is it Samsung, is it NVIDIA, is it Ubuntu Mate?

Will we ever know?


#4

Hi duvenhage
Lets give it a try :slight_smile:

First please post your computer specs. Open a terminal (Ctrl+Alt+t) and enter…
Code:
inxi -b

And whats xrandr have to say about all this?
Code:
xrandr

There is a GUI tool in your menu (System>Preferences>Hardware>Display). Have you tried this?

There is also the nvidia settings tool (System>Administration>Nvidia).

Give both a try if you haven’t already.

That above link will not work for updates, just the most recent install.


#5

I have also experienced this issue. In fact, my main install of Ubuntu Mate still reports that it is connected to a 7’’ monitor (it is really a 23’’ monitor).

In my case the issue began with the installation of Nvidia’s proprietary graphics driver (361.42 - GTX970).

Not only did it report the wrong monitor size, it also changed the system’s default DPI setting for rendering fonts (Appearance > Fonts > Details… > Resolution). Most displays should default to ~96 DPI; when I installed the Nvidia driver it rendered fonts so large that I was unable to even navigate to Mate’s appearance preferences.

Once the DPI setting was reset to 96, the issue was mostly resolved. Unfortunately, every time I log into my system (after the greeter disappears and just as the menu bars appear) the font still renders at its wrong, gigantic default for a second before redrawing with my custom DPI setting.


#6

Thanks for the response. Here are my answers:

inxi -b

System:    Host: Stonedown Kernel: 4.4.0-22-generic i686 (32 bit) Desktop: MATE 1.12.1
           Distro: Ubuntu 16.04 xenial
Machine:   Mobo: Acer model: Aspire T3-710 v: V:1.1 Bios: American Megatrends v: R01-A2 date: 12/31/2015
CPU:       Quad core Intel Core i7-6700 (-HT-MCP-) speed/max: 899/4000 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 745]
           Display Server: X.Org 1.18.3 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: [email protected]
           GLX Renderer: Gallium 0.4 on NV117 GLX Version: 3.0 Mesa 11.2.0
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           Card-2: Intel Wireless 3165 driver: iwlwifi
Drives:    HDD Total Size: 1256.3GB (10.6% used)
Info:      Processes: 230 Uptime: 6:02 Memory: 863.0/16150.6MB Client: Shell (bash) inxi: 2.2.35

`

xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1920x1080     60.00*+  50.00    59.94    59.93  
   1920x1200     59.95  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89    59.90  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1280x800      59.91  
   1152x864      60.00  
   1280x720      60.00    50.00    59.94  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   720x576       50.00  
   800x512       60.17  
   700x525       59.98  
   720x480       60.00    59.94  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05

System>Preferences>Hardware>Displays is where my 7" monitor is reported …

System>Administration>Nvidia XServer Settings says “Application profiles are disabled.” Maybe because I replaced them with Nouveau via System>Preferences>Hardware>Additional Drivers?

Looking forward to your feedback.


#7

That really threw me. How can you live with a 7" display? Now it makes sense. It just reports a 7", but you have full screen(as xrandr verified with the *+ next to it). LoL

Will this get fixed? Probably not. Its been going on for years. Some computers will report that there is no monitor.

Ok, about this nouveau driver. In your xini report. What is this?

It failed?

Is there a reason for not using the nvidia driver? I also run geForce (not near as new and shinny as yours :slight_smile: ) and always use their drivers, they have proven reliable for me. Maybe your newer setup requires this?


#8

I forgot..

And then there are those people that have all the luck :slight_smile:


#9

Easy man :slight_smile: It can report a pink elephant smoking a pipe and that’d be fine by me as long as what I’m seeing is my 24" Samsung :smiley:

NO IDEA why Nouveau failed. Flat out beats the crap out of me…

I tried the NVIDIA driver (again). Installed it, rebooted and, lo, the 7" screen was presented. Just to be clear: My whole monitor is filled,but everything is bigger, as if you’re viewing the 7" monitor at 400% magnification. So I reverted to Nouveau and things look ok, even though system->preferences->hardware->displays says that it is a 7" Samsung.

Go figure …

Anyway, thanks for the input. Appreciate it :slight_smile:


#10

Your welcome.

Xrandr will get you by if you need it.
https://wiki.ubuntu.com/X/Config/Resolution


#11

Did you ever get this resolved? I have the same problem. My Display shows up much smaller in system Preferences Displays than it does in Nvidia’s X Server Settings – where it is correct! That means I need to set HDPI myself rather than use auto. It’s a pain. So when I rebuild my system, which I do regularly, the install looks bad until I change HDPI in Mate Tweak. Ugh! So however Nvidia grabs the info works, but Ubuntu gets it wrong. I’ll open a new ticket on this, too, I think. Anyway, good luck. Cheers, M :wink:


#12

Hi,

I had the same problem. The screenshot that v3xx posted got me thinking: What if the problem is the HDMI port, what if that doesn't happen using DVI. So I bought an elcheapo HDMI-to-DVI cable, and bam!

Now my Samsung SyncMaster T260HD is correctly recognized... no more giant fonts.

Bye bye then, Davide