(Yet another) Wifi issue after suspend in Ubuntu Mate 16.04.3

Hi guys,

I’m posting here as having troubles with the wifi after suspend.

I recently bought a new pcie wifi card (TP-LINK TL-WN881N), and it all works great. Unfortunately, it seems things turn bad when I put my computer to sleep, as the wifi doesn’t work properly after waking up.

In face, the problem is weird. It does connect to the wifi network, connection is showed in nm-applet, connection seems alright in ifconfig, routes are fine, but it seems the drivers gets in a buggy mode where I cannot even ping (or reach in anyway) my gateway or any other location.

I tried different fixes, like the one here https://askubuntu.com/questions/761180/wifi-doesnt-work-after-suspend-after-16-04-upgrade or here https://askubuntu.com/questions/452826/wireless-networking-not-working-after-resume-in-ubuntu-14-04 and none of them worked.
The weirdest thing is, if I try to manually restart the network-manager service, things don’t get solved and instead I even get troubles listing the wifi networks. A reboot seems like the only way to solve the problem so far.

Here are some details about my card and driver:

$sudo lshw -class network
  *-network               
       description: Wireless interface
       product: RTL8192EE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlp2s0
       version: 00
       serial: 30:b4:9e:72:08:78
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ee driverversion=4.10.0-32-generic firmware=N/A ip=192.168.2.2 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:127 ioport:d000(size=256) memory:f7100000-f7103fff

Thanks!

No solution here. You may order a wifi dongle that does work while you are searching for a solution however.

See - https://www.amazon.com/gp/product/B003MTTJOY/ref=oh_aui_detailpage_o01_s01?ie=UTF8&psc=1

or see - https://www.amazon.com/gp/product/B00EQT0YK2/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

Both work well.

Thanks Michael, but updating my hardware (that I just purchased) wasn’t really an option.

In fact, there is a solution, and here is the fix: https://askubuntu.com/a/949644/620058

I’ll change the issue as resolved,
Cheers!

Outstanding. Thanks tbrcn.