[Zesty] Multiple applet crashes on login when using transparent panels

System:    Host: Edge Kernel: 4.10.0-20-generic x86_64 (64 bit)
           Desktop: MATE 1.18.0  Distro: Ubuntu 17.04

I’m using Marco + Compton, standard layout with a few customizations:

  • Both panels backgrounds have been set to “solid color” with 100% transparency
  • I have added a multiload indicator applet to the top panel.

When I login to my session, I have a flurry of applet crashes.
It didn’t happen when the panels were not transparent.

Can anyone else try and reproduce this?

Like this, correct?

I will tell you if it crashes for me!

1 Like

Yes, thank you for your time.

Edit: by the way, by "flurry" I mean:

Well, so my transparent panel is working fine, I am afraid…

Did you save the layout it in MATE Tweak?

No, shall I do that?

I don’t know what a “multiload indicator applet” might be but I am unable to reproduce your applet crashes.


Sorry, I meant the System Monitor applet.

Do they reload after clicking reload ?

Can you add to autostarts :

mate-panel --replace > allout.txt 2>&1

so we can grab the output and see wath is going on .
Be aweare that the output will be dumped to the file after relogin after 1 time login .
And paste the output of allout.txt (should be located in your home folder) ?

1 Like

Still unable to reproduce your applet crashes. Added System Monitor, made both upper and lower panels completely transparent (which makes reading upper panel text difficult), and logged out, back in, no problems. Rebooted, still no problems.

My main difference from your setup may be that I boot into 17.04 using a grub perameter, ro quiet splash video=SVIDEO-1:d to bypass some sort of video difficulty.

Good luck tracking this thing down ouroumov.

1 Like

I have been also having a similar problem same kernel and MATE version but with only one panel I think a modified Netbook layout, Also sometimes more applets crash than others and it does not happen with non-transparent panels

1 Like

Every time I boot my laptop at least a few sometimes almost all of my panel applets are quitting I do not remember having it when I ran 16.04 but it happens every time and is a bit annoying

Something like that?

1 Like

Yes sorry I found this after I had already posted it

Hello everyone, sorry for completely neglecting this thread for a while.

Yes, they do.

I should have mentioned that I’ve never, to my recollection, managed to trigger this using a panel replace command, and I’ve tried a lot of times.

I have moved @Bernie’s thread here to centralize posts about this issue.

@Wimpy, @monsta, since one other person has been able to reproduce, can you guys maybe provide further avenues of investigation?

The key points are:

  • Random amount (but usually a lot) of panel applets crashing on login
  • Crashes seem more regular after a reboot than a logout, but they still happen in both cases.
  • Only seems to happen with a transparent background for the panel.
  • The crashes don’t prevent correct respawn of the applets once you click on reload, so while blocking to show this error might be good from a developer’s perspective, it’s definitively not from a standard user’s perspectives.

Edit: Note, I’m pretty sure the following is (one of) the automatically generated bug report for this bug, but I’m unable to access the detailed report:


Yes, these kinds of reports by some bot are useless…
We need either a proper report with the full stacktrace (it should be generated when all needed -dbg or -dbgsym packages are installed), or a .crash file uploaded/attached somewhere.
IIRC .crash files can be found in /var/crash, that’s where apport places them.

1 Like

Thank you @monsta, I’ve reported this upstream and attached .crash files to the report:

1 Like

I just switched to using solid panels but I won’t be able to try anything
for a bit because my computer died but I believe the hard drive to be good
so I may eventually be able to get it running on a different computer and
ill see if it will crash the same as before

Update: upstream has fixed this by working around a problematic function. I’m not sure the fix will be backported to Zesty but at least there’s a chance it’ll make it into Artful.

Yeah, this is fixed in 17.10, and recently the fix has arrived into 17.04 as well.