16.04 / Steam / Laptop / AMD Drivers


just quite new here, migrated from Win7 over Ubuntu Studio to MATE 16.04, so this is my very first request. :slight_smile:

Quite satisfied with MATE after testing a while with minimalistic Xface desktop. Surely laptop is not meant to run games with big requirements, but it’s comfortable to run some of my Steam games on linux.

Currently I’m trying to convince my Laptop (Toshiba L650D-10H with Mobility Radeon HD 5650) to run Steam client. Unfortunately Steam won’t launch with free driver.

So, uninformed as I am, I thought installing former fglrx radeon driver for 14.04 will solve it. Well, it doesn’t.
Steam started and downloaded client update, but on last step it told me that I’m missing open GL support and ended.

Even my oldest pc with ancient NVIDIA 9400 GT graphic adapter is now running Steam, but not my laptop.

I actually read plenty of articles about AMD drivers and missing 16.04 support.
Is there any chance to get a solution on this?


Hi and welcome,

please see this thread about AMD support (or lack thereof):

1 Like

Thx the notice @wolfman , read about driver issue.

Just upgraded my laptop and now pc to 16.04 LTS Mate. On both systems I was able to install Steam without problem.

Unfortunately Steam won’t launch…well, it starts, but then it drops/crashes.
On Laptop I tried to install unsupported old fglrx Radeon drivers, as described in first post, and Steam started. It also started Steam update, but didn’t launch due to ‘missing OpenGL’ and ended.


  • Laptop: Toshiba L650D-10H, 4GB RAM, Mobility Radeon HD 5650
  • PC: AMD Phenom II 4X, 8GB RAM, HD 7950

I know there is a problem with current AMD graphic drivers, but even with the open driver it should be allowed to start Steam client and access my games. Probably Steam client needs update to let it work?

Anyone solved this issue yet?

Hi kepos,

open Welcome > Software > Fixes and try running those first, you may have broken packages?. :smiley:

Thx @wolfman, allready done.

Besides I requested support on Steam forums and today I got response with a workarround.

`Run this command to delete the runtime libraries known to cause issues

find ~/.steam/root/ ( -name “libgcc_s.so*” -o -name “libstdc++.so*” -o -name “libxcb.so*” -o -name “libgpg-error.so*” ) -print -delete

If the above command does not work, run the above command again, then run this command.

find ~/.local/share/Steam/ ( -name “libgcc_s.so*” -o -name “libstdc++.so*” -o -name “libxcb.so*” -o -name “libgpg-error.so*” ) -print -delete`

First command worked for me, while I now get notice Steam client might be outdated. But…at least it started.


Excellent @Kepos,

please tick the box under your own answer so it helps others!. (Marks it as solved) :smiley:

Instruction in this video fixed problem for me:

without fglrx driver

sudo apt-get install steam

LD_PRELOAD=’/usr/$LIB/libstdc++.so.6’ DISPLAY=:0 steam

sh /home/your directory/steam.sh

Warning: this solution (LD_PRELOAD on libstdc++) seems to work at first but some games won’t launch (I’ve encountered the issue with Borderlands:TPS a few weeks ago).

The only real solution is to remove libs from the runtime, as posted by Kepos above (though I’m not sure you need to remove libgpg-error).

1 Like

I get a syntax error when i try this:

bash: syntax error near unexpected token `(’

Same error message here.

Hi all,

try a manual install like this (32 bit instructions!. For 64 bit, follow the instructions: “If you are running 64bit system first enable multi-arch repositories.”):


1 Like

I still had a problem with an X error this way, but I found a solution here:

cd $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak
cd $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak

It looks like it just renames the libs instead of deleting them like above. Thanks for the help!

1 Like

This worked for me:

Run this command to delete the runtime libraries known to cause issues

~/.steam/root/ ( -name “libgcc_s.so*” -o -name “libstdc++.so*” -o
-name “libxcb.so*” -o -name “libgpg-error.so*” ) -print -delete

If the above command does not work, run the above command again, then run this command.

~/.local/share/Steam/ ( -name “libgcc_s.so*” -o -name “libstdc++.so*”
-o -name “libxcb.so*” -o -name “libgpg-error.so*” ) -print -delete

1 Like