16.04 Xenial Xerxus freezing (assumedly power related, not random)


I am using Ubuntu MATE 16.04, which is freezing up, meaning, I can’t move the mouse, switch to console or programs with alt + tab, even a press on the power button doesn’t initiate a shutdown. All I can do is do a hard shutdown.

I have seen this thread: Upgrade to 16.04 xenial is periodically freezing
However I don’t quite know my way around Ubuntu and Linux and am afraid to use fixes for my system which is different from that in that thread. I am able to use terminal, but I have no idea about the structure of linux and can’t read those logs. However I saw at the time of the crash in /var/log/syslog a long entry with /00/00/… over several (about 10) lines.

This is my computer: http://www.notebookcheck.net/Lenovo-ThinkPad-E460-Core-i5-Radeon-R7-M360-Notebook-Review.154657.0.html

I can also gerenate the freeze by unplugging or plugging the power cord back in. Also closing and opening the lid again will trigger the freeze. Which makes me think it is related to the power management, which I uninstalled but the problem remained.

I also did a reinstall of Ubuntu to no success.

I noticed that you've already done a re-install with no resolution to the problem

I have a Dell laptop that is working just fine when I close the lid. I'm responding with a suggestion where you might find some hints what might be causing this.

Because the log files are rather long, I propose that you force the problem to occur noted the timed when you close the lid. After you have recovered the system to working condition you'll be examining the kernlog. Using the Applications Menu choose System Tools>>Log File Viewer.

Click on kern.log and choose the most recent day. The time and date will be in lighter grey. The log is arranged in most recent on bottom. Look for text similar to [found on my working system when I closed the lid ...

PM: Preparing system for sleep (mem)

Hopefully you will find an entry indicating a error condition.

There is no entry at the time of the system freezing. Last entries are 6 seconds before, that’s before I closed the lid. None of the other logs in that viewer show anything at the time.

Apparently the freeze happens only if I close and open the lid with the power unplugged, e.g. running on battery.

Have you done a full system update?:


Unpluging or closing the cover would put the machine in suspend mode / sleep.
Same thing when being inactive for a while.

Read the following about power management :

Your box is not freezing, it’s just suspended but it can’t be waked up because of “power management” problem. For the moment you could disable the machine to sleep and have it poweroff instead.

Mate has a config tool for power, take a look at it.

This post is about debian having problem to wake up the machine once it is suspended :

You will have to google to find a solution I guess ? I’m not sure there is one for now.


I think that did it. I updated the just before to but still was getting the freeze.

Going through your guide, the only thing where there were updates or when there happened anything was during the dpkg in recovery mode.

Now I can’t recreate the freezing anymore. However I will wait some days to mark it as solved, just to be sure.

Many thanks!

1 Like

Thank you for the response and your idea, I will read into the power-management page.

There is a problem with your theory however, because the screen comes back up from being suspended. The clock ticks a bit and then it’s gone (That’s how I know when it freezes). I can’t do anything.

And I also get the freeze (they might be unrelated though) when unplugging or plugging the power chord back in, altough not every time, doing it a few times produced the freeze.

I thought you were really freezed!

Yes, I was. I couldn’t move the mouse, alt+strg+f1… didn’t to anything, keyboard didn’t do anything power button didn’t initiate shutdown. The laptop only went down after holden the power button for a few seconds. Is that not what you call it?

1 Like

wolfmans suggestion worked for me, I haven’t had that error since I followed the guide.

The “lightswitch”-sound didn’t occur before, when you plug in or plug out the power. I thought it’s curious and wanted to add it.

1 Like

I have solved this issue, … problem is with HDAPS, which is blocking HDD, Dont use HDAPS or change setting after installation before restart of pc. For my HP laptop i changed sensitivity from 15 to 98 in files /etc/hdapsd.conf . Now all is ok!!! Some crazy guy set a sensitivity on 15 (than default value), which is blocking sata hdd !!!