18.04 has no network icon!

I just installed 18.04, and there is no network icon at all, which makes it kind of hard to connect to wifi. I can run a CAT-5 upstairs and try to find a way to install that app, if it can be done.

Also, BTW, the Welcome window is missing.

Hi Frederick,

restart the live CD and choose “Try Ubuntu Mate”, you may have to restart a few times to get it to show but it should eventually!.

Failing that, you can manually set-up your network:

Top panel > System > Settings > Internet and network!. :smiley:

Thanks! I had some bad crashes, liike the desktop not loading, so I went back to 16.04, and will be more patient than to try a beta this soon!

Hi Frederick,

I did also have a couple of problems but there have been many more updates in the meantime.

Try a new daily build again and you should be good to go!.

http://cdimage.ubuntu.com/ubuntu-mate/daily-live/current/HEADER.html (Daily build from 18 march 2018). :smiley:

Just installed the brand-new 18.04 UM. STILL no wireless icon, and running nm-applet gets this:

sudo nm-applet

(nm-applet:7473): Gtk-WARNING **: 03:34:41.380: Can’t set a parent on widget which has a parent

(nm-applet:7473): Gtk-CRITICAL **: 03:34:43.609: gtk_widget_destroy: assertion ‘GTK_IS_WIDGET (widget)’ failed

(nm-applet:7473): Gtk-CRITICAL **: 03:34:43.609: gtk_widget_destroy: assertion ‘GTK_IS_WIDGET (widget)’ failed

(nm-applet:7473): Gtk-WARNING **: 03:34:43.621: Can’t set a parent on widget which has a parent

This is nonsensical to me. Why, when the installation disk has a wireless icon allowing a network to be selected and a password entered, does the installation, when booted, show no wireless icon?

I mean, it’s a good thing I have a long CAT-5 cable, but I shouldn’t have to connect with Ethernet!

CAN anything be done about this? It was also present in the beta, and I had expectations that it wouldn’t be in the final release.

Same problem here. I had the Network Manager applet showing up just fine on 17.04. After upgrading to 17.10 it disappeared, but I was able to get it back by using MATE Tweak to revert to a saved panel layout. Now, after upgrading to 18.04, it disappeared again. I am still able to recover it by reverting to a saved panel layout, but now I have to do it every single time I restart my computer. Very frustrating.

If I switch to the new default Redmond panel, there is a similar icon that stays on the panel permanently, but it is less functional; part of a set of five icons and doesn’t show the lock subicon to indicate a VPN connection.

If I run sudo nm-applet, I get similar error messages to the ones that Frederick_Wrigley posted, though the icon does display while I have the terminal open.

Here’s my error message when running sudo nm-applet (running it without sudo generates no error, but also doesn’t bring back the icon):

(nm-applet:2874): Gtk-WARNING **: 09:19:30.075: Can’t set a parent on widget which has a parent

(nm-applet:2874): Gdk-CRITICAL **: 09:19:30.274: gdk_window_thaw_toplevel_updates: assertion ‘window->update_and_descendants_freeze_count > 0’ failed

This sounds like a mismatch between the older notification area used in your older saved panel layout and the newer indicators, now used by default. Your best bet is probably to re-create your panel layout based on one that uses indicators (that’s what I did), or you will need to manually tweak things. See this thread (I haven’t tried it personally):

Yes, If I do run nm-applet, the wifi networks do show up. It did allow me to connect wirelessly, but I really do not want to have to run this every time I reboot.

I solved this in 18.04 final by adding to Panel ‘Indicator Applet Complete’ — it has Bluetooth, Network, Battery, Volume and Session. The old ‘Notification Area’ is still there, and it has Skype showing. At first everything else was missing, but now Volume has showed up again. I have 2 Volume controls, which I can ignore.

1 Like

You can also run the following terminal command in case of missing dependencies?:

sudo apt update && sudo apt dist-upgrade -f

1 Like

Isaiah_Sellassie, I appreciate the suggestion, but the Indicator Applet functions a bit differently. It is less customizable and also does not show the lock icon when connected to a VPN, for example.

wolfman, thanks as well for offering a possible solution. I tried checking for and addressing missing dependencies previous, but to no avail. The fact that the icon can be temporarily restored by loading an old panel configuration or by keeping a terminal open after running sudo nm-applet suggests that there’s not a missing dependency at play.

A bug has been reported for this problem:
https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/1754458

1 Like

I managed to make the network, keyboard and sound icons show again in the taskbar by doing the following and it doesn't require to re-run it each time you reboot:
editing /etc/xdg/autostart/nm-applet.desktop and changed

Exec=nm-applet

to

Exec=dbus-launch nm-applet

My nm-applet.desktop file looks like this:
[Desktop Entry]
Name=Network
Comment=Manage your network connections
Icon=nm-device-wireless
Exec=dbus-launch nm-applet
Terminal=false
Type=Application
NoDisplay=true
NotShowIn=KDE;GNOME;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=NetworkManager
X-GNOME-Bugzilla-Component=nm-applet
X-GNOME-UsesNotifications=true
X-Ubuntu-Gettext-Domain=nm-applet


I tried this but I only get to see the following, missing the network connection:

Does it still work for you? I see that a bug has been reported...

1 Like

Yes, the complete indicator applet is working for me.

I tried a panel reset with right mouse click but that didn’t help either. :pensive:

Are you sure you added ‘Indicator Applet Complete’? There is another one called ‘Indicator Applet’ that shows only some, presumably those that have current notifications.

Yes. :pensive: I just tried it again, same result.

Dashy’s solution to edit nm-applet.desktop to launch with dbus worked like a charm. Persists after reboot and everything. Thanks, Dashy!

2 Likes

This worked to me Ubuntu 16.04 Mate 1.12.1
I added "sudo" in front of "nm-applet" in "modify starting program" !

I think that the problem is when you upgrade from a previous version of Ubuntu Mate to 18.04. The top panel with the menu bar has changed in the latest version, and this causes conflicts.

To fix all the issues, just right-click on the top panel and press “Reset panel”. From that point, you’ll see that the menu has changed and that the “Indicator Applet” is the new widget for all your network, bluetooth and other options.

Moreover, I was also having problems with the (Caja) Dropbox icon not showing up, and now everything seems correct.

I hope this helps!

4 Likes

The reset panel worked great ! thanks a lot.

1 Like