Access rights, SMB connection of two boxes

I have been using elementary OS (Freya) on a x86 box for a while and recently installed ubuntu Mate 16.04.01 on a Mac G5 PPC. I set up a SMB connection with the x86-box being the server.

Now I created a Libre Office Writer text document on the x86-box and needed a snapshot of a spreadsheet I had created on the G5. No problem one would think. Opened the spreadsheet on the G5 and stored it on the x86-PC, opened it on the x86, but it was protected so I could not copy & paste or do any other editing. Tried to alter the properties of the document at the source, but that did not change anything.

So I did it the other way round. Opened the text document stored on the x86-PC via SMB on the G5 running ubuntu Mate, copied & pasted the snapshot of the spreadsheet in it, finalized the document and stored it again via SMB back on the x86-PC. Now I have the same problem: I can open the doc on the x86-PC, but it is protected against everything.

Pls. help! I understand data protection and security are big advantages of Linux in general. But for me it is a bit to much protection if the system does not allow me to access my own documents.

Is there a way to adjust the settings in either the file manager or Libre Office?

Typically, if I am having problems with permissions on a given file or folder, I open Caja as a super user with the following command in a terminal:

sudo caja

Once opened, navigate to the file or folder in question and right click it and select “properties”.

In there you should be able to change permissions from “root” to your own user name. Then close the proprieties dialog box. Then close the super-user version of Caja. Then if you open the file via your usual application and try and save, the permissions problem should be fixed.

If, on the other hand, the problems with permissions on the file is actually a secondary consequences of limited permissions in the folder or, even , the drive in which the file resides, then just move up the path and reset the permissions there (while in Caja super-user mode). When you click to confirm it will ask you if you want to reset the permissions on all of the files inside the folder. You should choose yes.

I do have permission, but whenever i try to set a group it wouldn't allow me

thx. That works well on the Mac G5 running ubuntu Mate. Although I already was able to change these settings using the “regular” file manager (Caja?), i.e. without sudo. Probably because I am logged in as the administrator of the G5.

But with sudo caja it does not allow me to change settings over the network, i.e. settings of a file stored on the x86-PC via SMB from the G5 PPC. I then copied the respective file from the x86-PC to the G5 PPC, altered the Access Rights there for “all others” from Read-only to read-and-write and copied the file back to the G5 PPC, but it did not make any difference there. Problem is that on the x86-PC I am running elementary OS (an ubuntu flavour) which has Pantheon Files as the file manager. I only can view file attributes there but cannot change them.

I am getting out of my knowledge zone here, but that sounds like you need to be on the machine in question and change the permissions fromthere. That being the case, it is certainly an inconvenience to not be able to do it remotely from a single machine, In which case, it might be worth setting up remote access to the desktops of all client machines such that you can virtually “locally” change permissions on files/folders/drives.

Finally, there is one other trick I use on Samba. In my samba config file, at the bottom of a given samba entry, I always put:

force user = username

Where “username” is your actual username. So, for example, I put:

comment = Temporary file space
path = /tmp
read only = no
public = yes
force user = stephen

I don’t know why or how the above fixes problems with samba permission. I was just told how to do it by another user on a forum. But, it does seem to fix them.

Your samba config file is at:


On my x86-PC I have the following two entries at the bottom of

path = /home/ulrich
writeable = yes
; browseable = yes
valid users = root

path = /media/HITACHI_1
writeable = yes
; browseable = yes
valid users = root

The first is my personal directory, the latter is an external USB-harddisk. You mean I should add
force user = ulrich
as an additional entry in both?

Yes, and I would also temporarily comment out the “valid users = root” line to see if it make a difference. I have never seen that in a samba entry before.

I would also add:

read only = no
public = yes

Also , see here for precisely how I set up my Samba network: