Access shares from iomega home media drive nas

Hello all, Hoping I can get some help here. I am trying to access shares from a iomega NAS from a newly installed Ubuntu mate.

First a brief summary of what and why I am trying to do.

My parents visited me and really enjoyed how all my media was avaible to any device in my house. I use Windows PC’s myself and have media servers set up on them. They wanted to be able to do the same at their house, but they don’t have any PC’s (only Android tablets and a OLD slow desktop), they do have a samsung smart tv(more on that later). So I started figuring out how I could set them up.

First thought, do it through dlna. I gave them a extra iomega home media network drive I had, hooked it up to the router, configured dlna, everything was sharing to all devices. But it was very confusing to them, not to mention their samsung smart tv sucks so much at video sharing via dlna. My father says he doesn’t understand and just liked how I had mine set up. I use Plex for a server.

I figure a raspberry pi 3 will work as a decent server and within their budget(should say my budget as I will not take money from them for this). Read about installing Plex on Ubuntu mate, everything seems possible. Read that I might have issues with the Nas share and Plex in Ubuntu, but figure I can read enough and figure it out. Well I am stuck before I can even start.

Later today I will be on my way to visit them for a few days to get this set up and explained. The raspberry pi should be there Friday. I figured I should figure out the setup before I leave so I have more time to visit with them.

So, i turn off all my devices besides my router and my iomega NAS to recreate their set up. I install Ubuntu mate to a live USB flash drive using LiLi on my PC. Start up Ubuntu mate and try to access windows shares via Places-network-windows network, and nothing, get a error stating “unable to mount location. Failed to retrieve share list from the server: no such file or directory”
I then try to connect to the iomega Nas via Places-connect to server-
Server -
Type - windows share
Share - movies
Folder - /movies
Domain - workgroup

Still no luck. Failed to mount windows share. No such…

Finally figure out I can’t access a window share, because there are no windows machine running. Start looking up how to get a samba server running on Ubuntu. Followed some guides and somehow my android device was able to see the smb share on the nas and access it, but was never able to access it from Ubuntu itself. Read more guides completely wreaked my Ubuntu setup, in process of reinstalling now…

I’m completely lost now, have no idea what guides I followed and what I did wrong.

So I am stuck at the very first point of my project :frowning: I can’t even get Ubuntu mate to find the shares of the iomega nas. The iomega nas has no user authentication, set up for everyone.

I just need Ubuntu to act as a smb server so I can browse the iomega nas, and after I can actually browse the share on Ubuntu, auto mount them at startup so I can direct Plex to the nas shares.

Been at this for 10+ hours, need to get at least a few hours sleep before my 3 hour drive to my parents, but I can’t stop thinking and reading and trying to figure this out.

I’m sorry for the long post, I felt it was important to provide all this information as I’m asking for assistance. Hoping someone can help me. I’ll have a fresh install of Ubuntu mate to try whatever is suggested.

Thank you for your time.

I’ve been successful using afp:// to access a NAS (connecting from Ubuntu MATE on a laptop)

1 Like

This may help:

ok, finally off the road, and ready to get back to this. Going to try the suggestions and post back.

Your advice in using afp was great, i am able to mount and browse the share using afp, I need to figure out how to automount the afp share to ub upon start up now. Thank you so much for your advice.

now to figure the samba thing out

so after following both suggestions, i can successfully connect to the drive via places-connect to network, using both afp and smb.

connecting via windows share without a username and password it says please verify your user details. So I added a user named share with the password share to the nas. I got connected , but am curious to why it asks me for a username and password when the shares are all open public shares.

When i try to connect via places - network - windows network - WORKGROUP - RING-MEDIA(name of the NAS) I get Opening “RING-MEDIA” You can stop this operation by clicking cancel. So i can not browse the shares from this method, have no idea why.

Now I need to auto-mount these share on start up, and from reading i would do this by editing fstab. I also need to add a sleep command to fstab for it wait for the network to come up when i do this on the raspberry pi. Problem is I have no idea how to do this. I have search for how to do this and after reading various guides that all differ a small bit I am confused once again. I would like to know how auto mount both smb and afp at start up so I have options. Can anyone provide assistance?

Thank you for all the help thus far. I appreciate it.

I have successfully mounted the shares of the NAS. I still have not been able to get them to automount at start up, i need to add a sleep command but am unsure of how, ill be reading about this.

I’m going to write the steps i took, it may help others, and also for a reference.

After install of Ubuntu Mate

followed Not seeing Windows network?

then open terminal
sudo -i
(to become root user)

mkdir /media/NAS/Movies
mkdir /media/NAS/Music
mkdir /media/NAS/Photos
mkdir /media/NAS/Public

cd /media/NAS
(to verify folder creation)

cp -p -a /etc/fstab /etc/fstab-old

su nate
cd ~
id nate
to get uid and gid

sudo -i

gedit /etc/fstab
was prompted to install gedit

added into fstab

Mapping Network Share Movies

// /media/NAS/Movies cifs username=share,password=share,iocharset=utf8,sec=ntlm 0 0

Mapping Network Share Music

// /media/NAS/Music cifs username=share,password=share,iocharset=utf8,sec=ntlm 0 0

Mapping Network Share Photos

// /media/NAS/Photos cifs username=share,password=share,iocharset=utf8,sec=ntlm 0 0

Mapping Network Share Public

// /media/NAS/Public cifs username=share,password=share,iocharset=utf8,sec=ntlm 0 0

(save and close)

mount -a

this mounts all the shares, but most run sudo mount -a at startup. Reading about sleep command for it wait, unsure of what and where to put it.

really have a hard time figuring out how to get the NAS shares to automount at startup. Only way I can get them to mount is by sudo mount -a.

Any suggestions?

someone says they got the automount to work here Mount NAS share at startup - #3 by favancini1108

favancini1108Jan 30I
had to add this command
"sleep 5"
before the "mount -a" command
so the raspberry waits for the network to be up

thanks anyway

but I have no idea what and where he added the command too. Where would i put this?

well I made some progress, but still haven't been abot to get my shares to automount at startup. But now I can at least mount the drives without needing root to mount.

Updated line example is as follows

Mapping Network Share Music

// /media/NAS/Music cifs user,username=share,password=share,sec=ntlm,uid=1000,_netdev 0 0

I read that _netdev should allow mounting after the network is up, but It is not working.


Been at this for another 11 hours straight. Could really use some advice.

I no longer need root to mount the drive via places or the sidebar in caja

When I boot up the nas shares are shown in places, and also the side bar in Canada. However, the path it is mapped to (media/NAS/folder) is always empty until I click the share under places or the sidebar in caja. After I click one of those the share populates.

I need the nas shares to be available upon startup without having to open them in caja, so other programs can access them, as this media server will likely never be used and likely never even looked at by my parents.

So I am assuming a startup command/script of some sort would accomplish this. If I could some how just automate the sudo mount -a command to run at start up without being asked for a password, I think that would help.

This is the last thing I need to figure out. And I am completely stumped :frowning:

The following is an old post of mine and may not be related. I use Samba for sharing. Also, I like my Samba shares to be fully visible in the places menu right from log in, without having to navigate to them. This was my solution for making that happen:

Well I finally got it working, its not a elegant solution but it does work.

An example of one of the additions to fstab is as follows

// /media/NAS/Music cifs ,user,username=share,password=share,sec=ntlm,uid=1000, 0 0

I then edited the rc.local. At first it was failing , I assumed it was failing due to the network not being ready when it ran, so I added a sleep command

sudo gedit /etc/rc.local


sleep 60s
mount /media/NAS/Movies
mount /media/NAS/Music
mount /media/NAS/Photos
mount /media/NAS/Public

and after a few seconds upon boot the shares appear on the desktop and are accessible from other clients as a mapped drive.

I know its not the best solution, but I will take it :slight_smile: I don't really know anything about linux and this whole project was figured out as i went.

If there is a better way to have the rc.local run after the network rather than using the sleep 60s I would love to know!