Acer WiFi is disabled by hardware switch / Hard Block / kernel

Hi,

Please could some one help?

Dose any one know how to get around a hard block on Wireless Network Adapter ?

The Wireless Network Adapter works fine in win 10 but WiFi is disabled by hardware switch in Ubuntu Mate 15.04.

There are no settings in the BIOS for the Network Adapter.
The laptops wifi key has no change when it is pressed.

These are the comands i've trid so far

sudo lspci -nn | grep 0280

02:00.0 Network controller [0280] : Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01)

sudo rfkill list all

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: acer-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

sudo apt-get install linux-headers-generic build-essential

Thank you

You must press the wifi key on your keyboard to unlock it ! (That’s what we call “hardware”).

Somewhere on the keyboard there must be a “wifi image” over that key. Just press it!

Regards,
BT

2 Likes

thanks but I’ve already tried that the WiFi key doesn’t do anything :disappointed:

I am running Ubuntu Mate on a HP 250 G3. I had exactly the same problem occurring two times right after flying from Germany to Canada. As nothing seemed to help, I had to reinstall the OS both times (sorry I don’t have another solution at hand.)
Regarding the “hardware switch”, Lenovo machines do have a “real” switch at the side of the laptop whereas HP’s switch merely consists of pressing f12 (although pressing f12 enables/disables WiFi, the little light next to the WiFi symbol stays red instead of turning green.)

I am curious to see if anyone has a better solution for the problem. Thanks in advance!

I had a similar problem with my hp pavilion.

I believe I used:

Sudo rfkill unblock all

I then figured a way to have my wifi unblocked every time I booted up but I can’t remember what I did but I’ll have a think about it today to see if I can remember :confused:

YES I found a fix!

The fix for my Acer Laptop and its WiFi Hardware block.

You have to blacklist the acer-wmi kernel module:

sudo nano /etc/modprobe.d/blacklist.conf
add blacklist acer_wmi as a new line at the bottom of this file.

then reboot.

8 Likes

Sounds amazing! Can you maybe tell me why your fix fixes the problem and what had caused it?

Ok my story,

A week or so ago I went out and brought a new “acer Aspire ES 15 ES1-521- 88R9” laptop to replace a old one.

The new laptop was just running windows so i wanted to dual boot with Ubuntu MATE 15.04.
Once i had a fresh install of Ubuntu Mate on the laptop i couldn’t connect to my rooter by WiFi. The WiFi was disabled by hardware switch. The first thing i tried was pressing the WiFi button on the keyboard but with no joy. Then searched the internet. Found a few posts on WiFi being blocked & tried a few different commands (some which are listed above).

The cause was/is looking to do with kernel 3.19.0-26-generic & Acer hardware by adding the line of code to the black list it to unblocked the hardware block on the WiFi.

1 Like

cool bro. You are life saver. Thanks a lot…!

1 Like

hey , did any one manage to solve the hard switch blocking staffs for wifi

Worked great for me, I’m running Ubuntu 14.04 LTS. Thank you!

1 Like

Dear CyberMaxpower,

Your fix worked greatly for me. I am having an acer laptop with amd A8 processor(Aspire ES 15)
Anyway. Thank you for this fix :slightly_smiling:

Thanks
Neo

1 Like

Hi ,
I am running ubuntu 15.10 and facing same issue of wifi hard blocked. I tried adding the line at the end of the file and rebooted still it did,t work. Pls help

Sure you got it right? Can we see it please.

Code:
cat /etc/modprobe.d/blacklist.conf

1 Like

i’ve only tried it on my own laptop which is a Acer Aspire ES 15 ES1-521-88R9.

have you tried the other commands like Sudo rfkill unblock all ?

Please can you give the make and full model number of your computer so someone else maybe able to help?

Hi,
Yes i tried sudo rfkill as well.
I have Acer Aspire ES ES1-521-899K laptop.
Its wifi is hardBlocked.

It worked . I entered bios using F2 and then reset the BIOS settings using F9 and it worked. :smiley:

1 Like

This is indeed the answer. Thank you kindly!

1 Like

Worked for me too. Thank you.

1 Like

Thank you for the solution!

1 Like