Add Grub/Splash screen to MATE 20.04

On MATE Bionic, I remember there is the screen with the MATE logo and the five dots. I kinda liked that. I upgraded to 20.04 after flashing 18.04 and now it is missing. I don't have problems in booting, and I am wondering if I can add this screen back when I boot up, shutdown, or reboot.

(Also in the future if I do have problems, also if you could tell me how to disable it for future reference)

it is called a Plymouth boot screen, it can be installed by sudo apt install plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text if these are installed and it is not working then there it may be a configuration issue of some sort

They are installed, maybe I can reinstall it. I'll reboot and see if it works.

Reinstalled and rebooted. Doesn't work..

Once plymouth theme is installed, and set as the default plymouth theme, you might have to update your initramfs if it is not done automatically.

sudo update-initramfs -u

Did that and rebooted. Still doesn't work.
I don't know what the deal is, but this doesn't work.

Can I install the Bionic version for this?

How did you set the default Plymouth splash ? What command did you type ?

Did you update the initramfs for the current kernel, or all installed kernels, and are you loading the correct initramfs at boot ?

Do you have an Nvidia graphics card, if so are you using the proprietary driver or the open source Nouveau driver ?

What boot options do you have in your grub configuration file, particularly for gfxmode, gfxpayload ?

Changed default with sudo update-alternatives --config default.plymouth
Updated initramfs with sudo update-initramfs -u

I am on a Raspberry Pi 3B.

What boot options do you have in your grub configuration file, particularly for gfxmode, gfxpayload ?

Where do I find the config file?


Do you have 'quiet splash' on the LINUX line ?

This is the contents of etc/default/grub


Do you see the grub menu when you boot? (If not, you can hold down shift during the boot process to display it). On the boot menu, press 'e' over your boot option in order to see the actual grub entries that will be executed. Make sure "quiet splash" is present, and check what is set for "gfxmode" (I think it should be keep).

If this was a PC I would not be afraid of reinstalling grub but I don't know if the Pi implements grub in a different way to a PC.

Other than that, I am all out of ideas.

I was holding [shift] after the rainbow screen appeared, but nothing.
I'm not sure if I even have a Grub menu.

This is the Grub menu for my Ubuntu (not MATE) VM in VirtualBox:
Screen Shot 2021-01-07 at 01.49.42 PM

I don't think I have this

Are you sure the Pi uses grub ?

I'm not sure it even does. Unless you're talking about NOOBS, BerryBoot, or PINN

If it doesn't use grub, which utilises the initramfs to display the boot splash, then I am all out of ideas.

Good luck.

Had a look through my old notes. In my case, I made a copy of an existing theme then hacked around with it. Here is what I did.

  1. Put the theme into the correct folder;
    The theme files are inside the theme folder, so in my case I have a folder ...
    ... which contains the theme files.
    (In your case, you installed a theme with apt so the theme folders will be in the right place.)

  2. Install the theme and set it as the default. Note: 'Install' in this case means to add it to the dconf database (I think!) and does not mean install it with apt.

sudo update-alternatives --install /usr/share/plymouth/themes/default.plymouth default.plymouth /usr/share/plymouth/themes/my_tweaked_theme/my_tweaked_theme.plymouth 100

  1. Set the theme as the default.

sudo update-alternatives --config default.plymouth

  1. Update the initramfs to include the new default theme

sudo update-initramfs-u

I hope this is of some use. I really am now all out of ideas.

Good luck.

I did what you said. Does this look correct?

In the image, I already updated initramfs. I rebooted and it doesn't seem to work. Should I try a different theme and see if it works?

You have to update the initramfs AFTER performing the other 2 commands, so that it includes the newly defaulted splash.

Perform the 3 steps I posted, in that exact order, and see if it works.

That's what I did. I did the two commands first then updated the initramfs.
Maybe this won't work on 20.04, which sucks. I was just hoping for this to look better. But I guess I can't.

It does work on 20.04, I have a working boot splash using this method. I think it must be something Pi specific. My Pi is headless so I don't know.

I guess it doesn't work correctly when you upgrade. It works fine on 18.04, and I have had suggestions on downgrading to that. But the main obstacles of downgrading to it is that many things aren't updated (For example, Python, LibreOffice, etc.).