Altril locking me up!

New user, 16.04 as a clean install for a couple of days but already fed up with a windows resize problem (dealt with in another thread) now I am getting freezes where although mouse moves, nothing responds. I have been doing various normal things, opening folders, Firefox browsing, checking portable hard-drive, connecting printer (bloody problems there too dammit) as I setup this new OS. I even tried a fresh install.

Every now and again, four or five occasions so far, I get the freeze. No obvious reason but I have seen a couple of times a dialog box saying ‘altril has a problem’ or similar. The box is obscured behind other windows. I am not even using Altril! How do I remove this nasty bit of stuff and what do i replace it with? Happy with Libre Office for now when checking documents so have no idea why Altril is intefering.

I do not like having to hard shut down every time to recover, and expect a few wrinkles although would prefer not to have them but this is too much - otherwise this Linux distro would be a good solution for me

HI @morgan,

try running "dpkg" per the update guide and see if that fixes the problem!:

1 Like

Thanks but no thanks. Not being nasty but not willing to go through all that recover and dpkg and network cable stuff frankly. I am not a techie or a linux experienced user, if nothing easier comes up then I will simply try another distro or revert. Two days already playing with this stuff is more than I can budget.

Hello @morgan

Is this your first time ever installing a Linux distribution on your system?

If so, then most probably you can install CentOS or regular Ubuntu and, I bet, you’ll have similar problems.

Speaking of which, you didn’t provided any details in regards of your physical setup (What box is it, laptop, clone, year purchased?)

I would like to push things a bit further by asking you what OS was installed on this machine before you went for Ubuntu Mate? And whatever it was, did it gave you any problems at all?

If you answered yes on my last question then I am 100% positive that those problems you’re having are most certainly pointing to faulty hardware (There might be capacitors on your mainboard that have started to leak if you’re on a tower that accumulate a lot of dust over the years…).

Anyways, not wanting to rain on your parade but blaming Linux is, by experience, the wrong way of doing things.

Just my 2 cents.



@Jim007 has reported an Atril-related DOS in the following thread:

So far, no one was able to reproduce his report.

One of the MATE devs has indicated a workaround to neutralize atril-thumbnailer in a comment:

You can also turn off preview of files in caja preferences (caja is the file browser):
In "Extensions" uncheck "atril properties"
In "Preview" set everything to "Never"

1 Like

I have solved the files explosion problem as noted under my original post. This did not solve the problem of the Atril-thumbnailer crashing.

In Caja Preferences, I didn’t have to go quite as extreme as you suggest to stop the crashing problem. Under Preview, I only had to change the setting for Text Files to Never.

This one change has solved, so far, the problem of Atril-thumbnailer crashing and NO “Atril-thumbnailer-xxxx” folders are showing up in my temp folder.



I was running Win10 with no problems at all apart from getting slow at times - so despite it is old, it functioned well with multiple open windows. It is a Lenovo laptop Thinkpad E520. I posted the specs elsewhere but repeat here below.

DLS, I understand your reluctance to blame Linux or Altril but if you had gone through my last couple of days setting up what is said to be an ‘easy’ transition from Win then you would understand why I am fed up.

I have run Elementary and Lubuntu and Mint dual boot on this machine but preferred this Mate from reviews. Those others however had no problems with window resizing, printer setup or freezing.

I did the suggested upgrade and update steps to no avail, it still froze again. It should be noted that a search on the ‘software package manager’ didn’t even show Altril when I searched. I was working on documents. I only had Firefox and another folder or two (docs and download) open, nothing ‘working’ otherwise.

Then I loaded on AppGrid and found Altril and uninstalled it. No problems since. Let us hope it stays that way.

Sorry, I do not have time or enthusiasm to follow up the problems or re-create, I lost two days getting things setup as it was essential i had a printer and I now have much busy work to do.

If events occur in future I shall try and find logs or whatever and report here. The ‘log’ shown in 'home/folder is empty.)

System: Host: x-ThinkPad-E520 Kernel: 4.4.0-45-generic x86_64 (64 bit)
Desktop: MATE 1.12.1 Distro: Ubuntu 16.04 xenial
Machine: System: LENOVO (portable) product: 1143AJ1 v: ThinkPad E520
Mobo: LENOVO model: 1143AJ1
Bios: LENOVO v: 8HET44WW(1.26) date: 08/07/2013
CPU: Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB
clock speeds: max: 3100 MHz 1: 896 MHz 2: 897 MHz 3: 898 MHz
4: 832 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
Resolution: [email protected]
GLX Renderer: Mesa DRI Intel Sandybridge Mobile
GLX Version: 3.0 Mesa 11.2.0
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.4.0-45-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169
Card-2: Broadcom BCM43224 802.11a/b/g/n driver: bcma-pci-bridge
Drives: HDD Total Size: 640.1GB (14.0% used)
ID-1: /dev/sda model: WDC_WD3200BEKT size: 320.1GB
ID-2: USB /dev/sdb model: Portable size: 320.1GB

Sorry to hear all of that but judging by the amount of people NOT having this problem this definately seems to be related to your system. Could you try the same ISO on another machine? At this point I fully understand you being fed up and wanting to rollback to a known-to-be-working solution but, sadly, this is the price to pay for UM freedom.

Best regards,

Time will be the problem for a while but I shall do that asap.

Btw, removing Altril from Mate 16.04 has solved it in this case so it would likely be software specific or software clash rather than my machine as nothing else is failing or freezing surely? Not that I am bothered either way, a solution is a solution and I am willing to assist so if there had been a log somewhere containing relevant info I would have posted it. Is there a system log anywhere of crashes or driver or display faults?