Automatic lock screen not activating

I installed Ubuntu Mate 16.04 yesterday and have been really impressed with it so far.
One problem I have just encountered, though, is that the screensaver won’t run and the lock screen doesn’t activate.
Does anyone know why this is happening and how to fix it?

I have tried Googling for the answer but found nothing.

Can you manually trigger the lock using CTRL + ALT + L?

Yes I can - and I have fiddled about a bit and discovered that screensaver works fine if I use Compiz but I was using Compton.

This is weird, I’m using Marco + Compton and I’ve no issue with the screensaver on two different machines.
Maybe take a look at the power management settings and the screensaver settings.

I think I have the same problem.

Manually locking the screen works.

Occasionally the screensaver will work, but rarely. The screen will fade to black, then come back on. It’s like the screensaver is being interrupted right before it starts.

I’ve tried it with all of the compositing options, and it didn’t help me.

1 Like

Me too have exactly the same problem…i thought it was just me because i’m only noticing it after i did change something on mouse settings…anyway, i was too lazy to google for a workaround until i saw this comment by @meatball .

As stated above, it sounds like power management settings. Should be set to never.

What should be set to never?

Its in your screensaver settings

Okay, I set both of those to never, set the screensaver to one minute, rebooted the PC, waited, and it did the same thing (fade to black, then back to normal).

Try reinstalling it. Open a terminal (Ctrl+Alt+t) and enter:

sudo apt purge mate-screensaver mate-screensaver-common && sudo apt install mate-screensaver mate-screensaver-common

I assume your fully updated.

Just found this at launchpad. Similar yes?

First, I did the reinstall, update, reboot, and it’s still happening.

Second, That does seem like a similar problem, although I’m using a desktop computer, not a laptop. It is 64-bit though.

Similarly to the bug report, on the few occasions that it has worked. The first time the screensaver comes on, then the password screen. The second time, the screensaver comes on, then no password screen. Which is like in the bug report, but again I’m on a desktop, so I didn’t unplug the power cable. Then from that point on it just does the fade out, then back on.

You could swap out your current screensaver and see if it resolves the problem.

sudo apt purge mate-screensaver mate-screensaver-common && sudo apt install xscreensaver xscreensaver-data-extras

You need to add it to your startup apps located in your system menu.

Name: xscreensaver
Command: xscreensaver -no-splash

Or wait for others to reply, I do not have any other ideas at the moment :frowning:

I went ahead and switched to xscreensaver, and it’s been working.

Hopefully someone comes up with a solution for mate-screensaver.

Thanks for getting me this far.

1 Like

I’m now affected by this too.
Still using Marco+Compton. Not sure what is causing it.
I’ve marked myself as affected on the launchpad bug report.
@meatball and anyone else affected, you should do the same.

1 Like

Here’s a fresh Launchpad bug report describing something very similar:

Bug happens when using Marco+Compton, switching to Compiz fixes it.

1 Like

I was also having this issue. If you prefer to use Compton, using xautolock with xtrlock can meet your needs in the meantime…

I had exact problem, but when I added second monitor on DVI, screensaver and auto lock bug disappeared. So there is maybe bug with display drivers over HDMI?

Motherboard has HDMI, DVI and VGA connector.

My primary monitor is on HDMI. Secondary on DVI.
I onced tried only VGA, but after boot there was no window for login, only background login image.

Motherboard: ASUSTeK COMPUTER INC., model H110M-A/M.2
CPU: Intel® Core™ i5-6402P CPU @ 2.80GHz
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Device 1902 (rev 06)

I really need the lock screen to be enabled at start up. I have a chance to sell some laptops to a school but they want the teachers to have one log on and the students another. This lock screen not working is going to be a deal breaker!