Bluetooth icon disappeared from panel

I went to use my Bluetooth headphones today, and the Bluetooth Icon was MIA in the top panel. I used bluetooth yesterday. Using Ubuntu Mate 22.04
bluetooth issue

Can I get it back? Thanks

Hi, @matetwo .

I'm also using Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") but I don't use Bluetooth. However, I've searched here in the "Ubuntu MATE Community" Discourse discussion forums for the same error message that you've included in your screenshot:

Connection to BlueZ failed

Bluez daemon is not running, blueman-manager cannot continue.
This probably means that there were no Bluetooth adapters detected or
Bluetooth daemon was not started.

[ "Close" button ]

I've found the following solution posted here, in the beginning of this year (on 19th January 2022), by @JohnW, for Ubuntu MATE 20.04 LTS ("Focal Fossa"):

Near the beginning of that post, @JohnW starts by describing the scenario that seems to be the same as yours:

"(...) Today I noticed that the Bluetooth icon was missing from my Ubuntu Mate 20.04.3 installation's Indicator Applet. It had been working perfectly, so I tried starting Bluetooth from the Indicator Applet's system settings and (after a long delay) got this error notification:

Connection to BlueZ failed
Bluez daemon is not running, blueman-manager cannot continue (etc...)

Later in that same post, @JohnW has written what has worked for him:

"(...) This "Ice Cold Boot" if we can call it that, is what immediately worked wonders:

  1. Shut down.
  2. Unplug PC.
  3. Long-press power button (still unplugged) 10 seconds.
  4. Plug in and power up.

Gleaming in my Panel's Indicator Applet icons was my friendly oval blueman buddy, with the familiar red x in his pocket. I clicked him, clicked Turn Bluetooth On in the popup, and the red x vanished as hoped. I happily sent a test file to my phone. In short, it's working perfectly again. (...)"

I hope this helps :slight_smile:


Hi ricmarques,

I tried your solution and it worked.

Thank you...


1 Like

I realize that this is slightly off-topic, but wanted to add that I had the same issue after installing the 5.15.0-48-generic kernel on Linux Mint 21 (it was working fine on the previous 5.15.0-47-generic kernel).

I applied the above fix and it worked.

Thanks for the assist!