Broadcomm wireless not supported again


#1

I have a Broadcom BCM4313802.1 bgn wireless network adapter. I dist-upgraded to linux-image-4.15.0-29. My wifi failed to work, or even load. This is the second time since Mate 16.04 was released the new kernel failed to support my Broadcom card. Last time I just went back to the old kernel and waited for the next kernel upgrade. I also went back to kernel 4.13.0-45 this time so I still have wifi and I removed kernel 4.15.0-29. If you have a broadcom wireless network adapter be careful with this upgrade. I have not had any trouble with wireless card upgrades on other machines that are not Broadcom.


#2

Please see my tip on how to deal with broadcom drivers -

It is generally the first thing I do when installing a new distro or version of MATE. Good luck @jymm.


#3

I already have firmware-b43-installer installed and I do/did not have bcmwl-kernel-source installed.


#4

That happened to me too a few months ago. See -

You should file a bug report on the kernel. I am also running 4.15.0-29 but on 18.04 instead of 16.04 and wireless works fine.


#5

Thanks for trying to help, but I am a pretty casual user of Linux and a lot of what you posted is over my head. I will probably just wait out the new kernel like last time. I always keep the last kernel in case of problems like this one. I plan to upgrade to 18.04 soon anyway. I have 18.04 on a different machine and am still working on the tweaks I want before installing it on my main machine. I do love the Mate desktop.


#6

There are multiple Broadcom wireless cards and several different drivers. Bcm4313 is supposed to work out of the box in Ubuntu. What can stop it working is if you manually install the wrong driver.


#7

Check you have the latest linux-firmware package.


Wireless no Longer Works after Mate update - LTS 16.04.1
#8

It did work “out of the box”. It has quit working twice on me after kernel upgrades (dist-upgrade). I have never manually installed any drivers, or know how to manually install drivers. As I said, I am a pretty causal user, I don’t even understand some of the suggestions made here. The reason I chose Ubuntu Mate is usually everything just works, and I love the Mate desktop.


#9

Problem solved. I updated to the Linux4.15.3-0 kernel and all is working again. While looking for information I stumbled across the “Ukuu Kernel Update Utility”, which allowed me to update the kernel automatically. It worked well for me.

If anyone is interested here are some links;
http://ubuntuhandbook.org/index.php/2017/02/ukuu-install-latest-kernels-ubuntu-linux-mint/

another variation:
http://ubuntuhandbook.org/index.php/2018/08/uktool-tool-to-install-latest-kernels-ubuntu/


#10

UKUU is awesome, I swear by it!