Cairo-dock Issues in 22.04

Hi All
I am a fairly experienced Linux user and have had Ubuntu Mate since 18.04 but this is my first post so please bear that in mind :slight_smile:
I've been looking to upgrade to 22.04 but when I tested the upgrade (from 18.04 to 22.04) on a VM I experienced issues with cairo-dock.

I've used cairo-dock on Ubuntu since 18.04 and it's worked a treat, however it's failing now with the upgrade to 22.04.1: instead of opening the program when clicking the icon it thinks you want to move it.
Every icon every time.
It was working fine before the upgrade.
Even a brand new 22.04 install doesn't help.
Has anyone else had this and or offer any advice?

1 Like

I used to use Cairo-Dock but found it required too much tinkering, to load or keep it loaded. Switched to plank with no issues, but it doesn't do as much as Cairo-Dock. Just a thought. Just choose "use dock" in the MATE Tweak panel setting

1 Like

The Plank dock already comes pre-installed in MATE and has always been a better option I think, and Martin Wimpress the MATE developer chose it. You can bring it up manually or use the Pantheon theme or the Mac-like theme and it shows up on the center bottom with either a task bar or global menu on top. That’s one of the nice things about MATE; switching the look and theme is easy. :v:


Welcome @akemp77 to the community!

Thanks for the replies.
I have tried Plank but it doesn't allow for pinning documents so easily - in cairo-dock it's a few clicks but in Plank I have to create a desktop file manually, which is time consuming and fiddly, hence why I prefer to get cairo-dock working, if possible.

1 Like