Cannot change two-finger click emulation

As it says on the title, I cannot change the two-finger click emulation of the touchpad. No matter what I choose in mouse preferences, it acts as a right mouse button. Three-finger click emulation works as it should when I change it.

If I run the command synclient TapButton2=2 the two-finger emulation changes from right click to middle click as it’s supposed to.

1 Like

Hi @lepa22,

add the command to Control Centre > Personal > Startup Applications!. :smiley:

1 Like

Thanks for the reply @wolfman! :slight_smile: I know I can do that. The thing is that this was supposed to be done through mouse preferences. Adding the command as a startup application solves the problem, but it is a workaround, not a solution. It is not the intended way of Ubuntu Mate to do this.

I mainly wanted to point this problem out, so it can be addressed by someone who knows how to. Maybe I posted it in the wrong category. Perhaps “Thought and feedback” is a more appropriate category for this, so an administrator can move this if he thinks so. :confused:

Thanks again!

1 Like

We can move it, but you should be able to change category or other things by clicking on edit if you want.

Bugs can be verified here and mate related bugs can at times be repaired here, but to do it right a bug report should be opened and pointed at the correct package.

What about dconf, will it work?


@anon42388993 I didn’t know I could change the category. Thanks for the info! :slight_smile:

It doesn’t work with dconf too.

Hi @lepa22,

have you done a full system update which may help solve the problem?:

Yes, of course.

Btw, adding the command synclient TapButton2=2 to startup programs doesn’t seem to work. The same with some other suggestions I found online.

I also found a bunch of bug reports about this problem on launchpad, but they are all unassigned.


try installing the following package with this terminal command (Ctrl + Alt + t):

sudo apt-get install xserver-xorg-input-mtrack

and restart your PC!.

I cannot say whether or not this will help but you have nothing to lose!. :smiley: :thumbsup:

Nope, no change. :confused:

Anything here?:

Unfortunately no. I have already tried to edit the /usr/share/X11/xorg.conf.d/50-synaptics.conf file, as the article suggests, but the changes don’t take effect, even after rebooting the pc.

I think I have no choice for the time being than staying with the default configuration, i.e. two-finger tap -> right click.

Sorry @lepa22,

but I don’t have anything else for you!. :frowning:

Thank you either way @wolfman! :slight_smile:

1 Like

I assume you’re using Ubuntu MATE 16.04? If so, have you upgraded to MATE 1.14? If not, I suggest you do. Trackpad support was further improved in 1.14.

1 Like

@lepa22, here is the link to the info that @Wimpy suggested:

1 Like

Yes I have, since the first day it was available…

1 Like