MATE Desktop 1.14 for Ubuntu MATE 16.04 is available now

desktop

#1

The number one question in the Ubuntu MATE community right now is:

When can I get MATE Desktop 1.14 for Ubuntu MATE 16.04?

The answer is, now. Right now.

We’ve published a PPA containing MATE 1.14 that is designed to work with Ubuntu MATE 16.04. You can find out what changed in MATE Desktop 1.14 from the upstream release announcement.

You might be wondering why it has taken 2 months to release this PPA? Here’s why; they’ve been well tested.

The packages in this PPA are derived from the MATE Desktop 1.14 packages that were recently uploaded to Debian unstable. The upgrade issues encountered in Debian unstable have been fixed and all the packages have transitioned to Debian testing. All the upgrade fixes are included in this PPA to ensure a smooth transition. We also waited for the first MATE Desktop bugfix release, so what you are getting today is actually MATE Desktop 1.14.1.

Upgrade to MATE Desktop 1.14.x

To upgrade Ubuntu MATE 16.04 to MATE Desktop 1.14.x do the following:

Open a terminal using CTRL + ALT + T.

sudo apt-add-repository ppa:ubuntu-mate-dev/xenial-mate
sudo apt update
sudo apt dist-upgrade

Now restart your computer and you’re running MATE Desktop 1.14.x :-)

Notes

Upgrading to MATE Desktop 1.14 will remove the mate-netspeed packages, but don’t be alarmed, the NetSpeed applet is now included in the mate-applets package. You won’t loose any functionality.

If you see the following prompt during the upgrade, then press Enter to accept [default=N]:

Configuration file /etc/xdg/autostart/mate-volume-control-applet.desktop
 ==> Deleted (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainers version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** mate-volume-control-applet.desktop (Y/I/N/O/D/Z) [default=N] ?

The version of MATE Desktop 1.14 in this PPA is built against GTK2+ to ensure compatibility with Ubuntu MATE 16.04 and all the 3rd party MATE applets, plugins and extensions.

We hope you enjoy using MATE Desktop 1.14 on Ubuntu MATE 16.04!


Tmp folder filling up
Mate Weather Applet not working completely
MATE Desktop 1.16 for Ubuntu MATE 16.04
MATE 1.14 built against GTK2 will come to a PPA for 16.04
Cannot change two-finger click emulation
New to MATE, trouble with Compiz and hotcorners
#2

I love it :slight_smile: but just wonder why not put it in the welcome center?


#3

We may do that. I’m just not sure where the best place for it would be. @lah7 Thoughts?


#4

Oooh, I know a good place for this in the Boutique – the home page – only it doesn’t exist yet. :slight_smile: (It might not until 16.10)

It could be listed as an upgradable piece of software, like LibreOffice?


#5

This is great news thanks so much for sharing it with us all.

How would this Impact the already 16.04 desktop environment I’m already using


#6

Installed, went pretty well, couple o’ issues…The screensavers package does not seem to want to download, just locks up 7 when you try to reboot at-spi-registryd.desktop error, any pointers?

Looks great otherwise Wimpy!!


#7

I installed the PPA and cannot really comment yet as to how good or bad it is as I don’t really do anything in Caja except store my files!. :smiley:


#8

Working here too. x220 Lenevo.

On first boot I got a terminal window in top R.H corner with lime green text, and another quite large window with a “tilda” configurator (?) with multiple tabs.

I exited the terminal window and rebooted again - all was good.

Any idea’s?


#9

Wolfman is this upgrade supposed to make a difference in a desktop environment using this


#10

Installed it just yesterday, looks and acts the same. No problems at all on my end. Great work Wimpy!

Though where is this OSD control for volume and brightness?


#11

To be honest Rob I haven’t really noticed any changes in performance etc, as I pointed out above, I don’t really do anything with Caja so cannot really comment!.

Wimpy provided the PPA for those that want the “cutting edge” software and that’s all I really know!. :smiley:


#12

Yeah I’m running three mate machines and only upgraded one with this upgrade but I don’t really see any change so I’m not sure what it really does


#13

Just read the release notes :wink:


#14

Thank you very much Wimpy et al., everything working great here.


#15

At what point will this actually make it into the standard Ubuntu MATE?


#16

I seem to remember it’s the default for UM 16.10


#17

It won’t make it to the Ubuntu MATE 16.04 archive, the PPA I’ve published is the only way to get it for 16.04.


Possible memory leak in mate-panel?
#18

Works as intended - love it :heart_eyes:


#19

How do you get the “about MATE desktop environment” screen?


#20

It’s in the System menu if you are using the standard Applications Places System menu, or under a System subheading if you’re using a combined menu.