Cannot install or even try Ubuntu MATE 16.04. Graphics problem?

Hi! I’m having a tad bit of a problem trying to get Ubuntu MATE 16.04 installed on my desktop. See the issue is: I can get it booted just fine. But after the ‘loading screen’, all I get is “Input not supported”. And this is on my computer with a PNY Nvidia GTX 960. I’ve even tired it with my brother’s Evga Nvidia GTX 750 Ti and the same thing happens. But if I use my systems Integrated Graphics it’s works fine…

Any idea why this is happening? i can’t even get drivers installed to see if it’s drivers. (No screen input).

My system specs are:
AsRock Extreme6
Intel i5 4570 (3.2 GHz)
Ballistic Sport RAM (8 GB)
tried with both:
PNY Nvidia GTX 960
Evga Nvidia GTX 750 TI
my main GPU is the GTX 960

Is it a driver issue? if it is, should I install the drivers while using the integrated graphics then use the graphics card?

Thanks a billion!

I just ran into this today, took me about half an hour to figure it out. Finally I found that if I left it long enough it would boot after the Not Supported message from my monitor. Eventually the screen does come back and Ubuntu MATE is accessible. The next thing to do is to check under System menu, Preferences, then Hardware and check for Additional/Proprietary drivers(that will take a minute). Then select to use the Nvidia Driver, the default Xserver driver will probably be what is selected(that’s what is taking so long to boot).

I just went through this today after a reinstall, with my Nvidia 980ti, so I’m pretty sure you have the same thing going on.

If the driver is not there, then you will need to go to Nvidia and download the correct driver and install. Feel free to ask, if you’re not sure. I had to do that just a few days ago.
Good luck!

I’ve noticed something else now. I’m not sure yet how it figures in to the Nvidia driver issue. Mine is not booting without having the USB boot drive in the USB. I’m wondering if I had the USB drive in when I installed the driver and it put the drivers on the USB, or if there is a driver on the boot device, that’s not on my desktop hard drive, that lets it boot to the log in screen and then starts using the Nvidia Drivers. I’ve asked about this on another topic board, but I thought it might mean something to you, since we are both running the Nvidia GeForce graphics cards.


can you see the Grub menu when booting?, if you can, press "e" (Edit) and type "nomodeset" then press enter and see if it boots!.


please see this guide:

1 Like

Tried nomodeset in grub and got ‘command not found’. Not sure what that’s about. It is booting with the USB installer disk in, so I went and checked the drivers again. Nvidia driver was still on, but the amd-64 microcode driver was not. So I turned that back on and it seems to be acting properly now. Booting up with no problem. Don’t know why that worked, but it only shows ‘not supported’ for one second then I’m at the log in.
Haven’t heard back from Joey17, hope they got theirs working. Anyway
It’s working for me, so I’m not arguing with it.
Thanks again, Wolfman.

1 Like