Can't access BIOS after installing Ubuntu Mate

I've installed ubuntu mate (dual boot with win8) for a month ago.
The problem starts when i want to enter BIOS menu. When i turn on my laptop, it doesn't show screen like "Press F2 to enter bios menu", but grub appear and i can boot normally

After i encountered that problem, i try to install lenovo onekey recovery and boot up my laptop again using "recovery button" on my laptop. When boot up it show a menu where i can choose option like "Select boot disk" "recovery menu" aanndd "Enter BIOS menu". But Everytime i choose "Enter BIOS menu" option, it doesn't show BIOS menu, it show grub menu instead where i can choose which OS i want to boot.

Can anyone have solution so i can access BIOS menu again? i've already tried using boot-repair and grub-update.

Thanks before

Have you tried solutions from this page ?

Ubuntu will definitely not have changed your BIOS settings such that you are unable to get into BIOS because of Ubuntu. Ubuntu's operations happen after the BIOS has loaded.

Ordinarily, to get into BIOS, immediately following physically switching the machine on, you need to press the F2 button repeatedly (not via a single continuous single press) until the bios appears. If that does not work, you should press the ESC key repeatedly instead.

Have you done the above?

I've tried :

  1. Reinstall windows using ISO which opened inside windows without clearing data(hope it reset my laptop)

  2. Pressing F2 repeatedly for like 10+ boot

  3. Unplug my boot drive

  4. Hold Esc and or press it repeatedly(+F2)

  5. "exit" in grub (it brings me to select boot drive only)
    https://i.imgur.com/npQQLEe.png(new user only can post 1 image)

  6. Pressing another key instead of F2

  7. Changing the "GRUB_CMDLINE_LINUX_DEFAULT" variable

but something that makes me wonder if is my BIOS corrupted or something is i can access to this screen


but when i choose BIOS setup, it only and always load the grub https://i.imgur.com/4RprGzZ.png(grub screen)

Ordinarily, to get into BIOS, immediately following physically switching the machine on, you need to press the F2 button repeatedly (not via a single continuous single press) until the bios appears. If that does not work, you should press the ESC key repeatedly instead.

Yes, i've done this. Even i tried to press F1, F3, and any other key except F12(it show select boot menu)

Looking at the image you linked of your Grub screen you are using UEFI. You also mentioned using Windows 8.

There is a possibility that you are configured to use Fastboot in Windows and this is creating a condition where the option to enter into BIOS/UEFI goes by so fast that the F2 key-press isn't being able to be registered.

You may want to refer to this article on Fastboot and disable it if it is enabled. I am unable to provide much more trouble shooting on the Windows side but I have seen similar issues reported in web search of issues you are describing.

Thanks, but i've tried it and it only does affect how windows start up not how the computers boot